Bug 130350 - hw_random not found
hw_random not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 130368 (view as bug list)
Depends On: 151403
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-19 10:41 EDT by Sammy
Modified: 2008-05-23 12:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 15:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-08-19 10:41:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
During boot rc.sysinit calls rngd which produces an error stating that
hw_random cannot be found. Should there be a file /etc/rc.d/init.d/random?
This is mentioned in /etc/readahead.early.files! If hw_random module
is started there is no error.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-12.1.142

How reproducible:
Always

Steps to Reproduce:
1.install kernel-utils-2.4-12.1.142
2.reboot
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-08-19 15:22:44 EDT
*** Bug 130368 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-08-19 15:22:52 EDT
This will get created by udev in the near future.
Comment 3 Bill Nottingham 2004-08-20 00:29:06 EDT
A check for the device node is in initscripts-7.64-1.
Comment 4 David Lehman 2005-02-04 17:45:46 EST
The check will never succeed AFAICT, because it checks for a regular
file, not a character device.
Comment 7 H. Peter Anvin 2005-09-28 14:22:12 EDT
In current rc.sysinit, this test is:

#[ -x /sbin/rngd -a -c /dev/hw_random ] && rngd

... which looks correct, except for the fact that it's commented out!  This is a
major loss for a hwrng-equipped server.
Comment 8 Bill Nottingham 2005-09-28 15:16:26 EDT
rngd hangs if the hw_random device exists (the module is loaded) but there isn't
any specific hw RNG backend. Behavior like that isn't really appropriate in
rc.sysinit. :)
Comment 9 Matthew Miller 2008-05-23 12:19:50 EDT
Just a note: see bug #215371 for related discussion.

Note You need to log in before you can comment on or make changes to this bug.