Bug 1502021 - rbd-target-gw does not support cluster name different than 'ceph'
Summary: rbd-target-gw does not support cluster name different than 'ceph'
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 3.1
Assignee: Jason Dillaman
QA Contact: mkasturi
Aron Gunn
URL:
Whiteboard:
Keywords:
: 1503556 (view as bug list)
Depends On: 1635924 1459861
Blocks: 1494421 1584264
TreeView+ depends on / blocked
 
Reported: 2017-10-13 18:22 UTC by leseb
Modified: 2019-01-10 16:22 UTC (History)
12 users (show)

(edit)
.The iSCSI gateway supports custom cluster names

Previously, the Ceph iSCSI gateway only worked with the default storage cluster name (`ceph`). In this release, the `rbd-target-gw` now supports arbitrary Ceph configuration file locations, which allows the use of storage clusters not named `ceph`. 
 
The Ceph iSCSI gateway can be deployed using Ceph Ansible or using the command-line interface with a custom cluster name.
Clone Of:
(edit)
Last Closed: 2018-09-26 18:16:44 UTC


Attachments (Terms of Use)
ansible-vvv.log (2.24 MB, text/plain)
2018-07-03 14:53 UTC, mkasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2819 None None None 2018-09-26 18:18 UTC
Github ceph ceph-iscsi-config pull 30 None None None 2017-10-13 18:22 UTC

Description leseb 2017-10-13 18:22:37 UTC
Description of problem:

rbd-target-gw has hardcoded ceph command.

Version-Release number of selected component (if applicable):


How reproducible:

Deploy a cluster with a name different than 'ceph', try to start rbd-target-gw.

Steps to Reproduce:
1.
2.
3.

Actual results:

Daemon fails with:

Oct 13 16:20:29 ceph-iscsi-gw0 systemd[1]: Started Setup system to export rbd images through LIO.
Oct 13 16:20:29 ceph-iscsi-gw0 systemd[1]: Starting Setup system to export rbd images through LIO...
Oct 13 16:20:29 ceph-iscsi-gw0 rbd-target-gw[5975]: Processing osd blacklist entries for this node
Oct 13 16:20:30 ceph-iscsi-gw0 rbd-target-gw[5975]: Failed to run 'ceph osd blacklist ls'. Please resolve manually...
Expected results:

Runs normally:

-- Logs begin at Fri 2017-10-13 15:36:46 UTC. --
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: No OSD blacklist entries found
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: Reading the configuration object to update local LIO configuration
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: Processing Gateway configuration
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: (Gateway.create_tpg) created TPG '1' for target iqn 'iqn.2003-01.com.redhat.iscsi-gw:ceph-igw'
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: (Gateway.create_target) created an iscsi target with iqn of 'iqn.2003-01.com.redhat.iscsi-gw:ceph-igw'
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: Processing LUN configuration
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: No LUNs to export
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: Processing client configuration
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: Adding the IP to the enabled tpg, allowing iSCSI logins
Oct 13 17:19:06 ceph-iscsi-gw0 rbd-target-gw[20764]: iSCSI configuration load complete


Additional info:

Comment 4 leseb 2017-10-18 08:38:32 UTC
We fall into the category "Services don't start (e.g. can't launch monitor or RGW, etc.) when following prescribed methodology in published product documentation", but the workaround can be "don't use a ceph cluster name different than the default 'ceph'.

So I don't know.
Federico, can you help us with this?
Thanks.

Comment 5 Jason Dillaman 2017-10-18 13:05:04 UTC
tcmu-runner doesn't support a cluster name other than "ceph", so I think this just becomes a release note / doc update saying that is iSCSI is being utilized, you must name your cluster "ceph" (or manually copy the generated "/etc/ceph/<cluster name>.conf" to "/etc/ceph/ceph.conf").

Comment 6 leseb 2017-10-18 13:20:19 UTC
*** Bug 1503556 has been marked as a duplicate of this bug. ***

Comment 7 Federico Lucifredi 2017-11-02 23:58:17 UTC
I thought Sage was obsoleting cluster names with Luminous anyway?

Comment 8 leseb 2017-11-03 08:15:42 UTC
AFAIR the plan is to keep cluster name around for containers and clusters on demand purposes.

Comment 15 mkasturi 2018-07-03 14:53 UTC
Created attachment 1456259 [details]
ansible-vvv.log

Attaching the ansible log

Comment 30 errata-xmlrpc 2018-09-26 18:16:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.