Bug 150238 - Anaconda Ignores Device directives in kickstart file
Summary: Anaconda Ignores Device directives in kickstart file
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-03 21:38 UTC by Ron Reed
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 21:16:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ron Reed 2005-03-03 21:38:20 UTC
+++ This bug was initially created as a clone of Bug #147687 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

Description of problem:
I have some PowerEdge 2550 servers. These servers have both the internal
PERC 3Di raid and a PERC 3Dc card in them.

I am working on creating a Kickstart CD and I have a problem with the
order of how the raid devices are installed. The PERC 3Dc (megaraid) is
found first and gets set-up as /dev/sda, the PERC 3Di (aacraid) get
detected second and gets set-up as /dev/sdb. I need to get the 3Di to be
/dev/sda during the install.

Version-Release number of selected component (if applicable):
anaconda-9.1.4.1-1.RHEL

How reproducible:
Always

Steps to Reproduce:
1. Boot the bootdisk.img from a standard RHE3.0-WS CD
2. At the boot: prompt type vmlinuz initrd=initrd.img ks=cdrom:/ks.cfg

  

Actual Results:  The install will start, but the megaraid device is setup as
/dev/sda and the aacraid device is setup as /dev/sdb

Expected Results:  The device parameter in the ks.cfg file should have set the
aacraid device as scsihost0 and allowed the kernel to set it up as /dev/sda.

Additional info:

Comment 1 Chris Lumens 2005-03-11 16:24:57 UTC
Marking as NEEDINFO based on comments to anaconda-devel-list.  Will post a link
to the relevant archives later so we can keep this all in sync.

Comment 2 Jeremy Katz 2005-09-21 21:16:07 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.


Note You need to log in before you can comment on or make changes to this bug.