Bug 150269 - DVI panel loses sync when anaconda starts X with unknown monitor type
DVI panel loses sync when anaconda starts X with unknown monitor type
Status: CLOSED DUPLICATE of bug 151474
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-03-03 20:40 EST by Justin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-18 01:12:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin 2005-03-03 20:40:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12

Description of problem:
Basically I am using an Apple 17" LCD display with a Radeon 9000 on an older dual proc P3 box.  The Radeon 9000 is detected, but the monitor type is set as "unknown", and as soon as it attempts to start X, it shuts down the DVI output from the card and lights the analog one.  I tested it by connecting an analog display after it kills the DVI display and it is sending signal to the analog vga output of the card after that.  This is a real problem if, like me, you have a DVI-only monitor.  I had to hook up the VGA input from my rear projector to confirm this problem, and then had to do the install from the ascii installer.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect a DVI-only flat panel of a type unknown to FC3 to a Radeon 9000.
2. Boot from install CD, select graphical installation
3. On start of X, DVI panel will lose sync and analog VGA output on card will light.

Expected Results:  There should at least be an installer switch allowing this to be overridden. It should be smart enough to detect that the unknown monitor it probed is connected to the DVI output of the card.  It should have a configuration profile for detecting Apple displays.

Additional info:

Note that I am using an Apple display that has the proprietary ADC connector on it, so I am using a separate device to do power injection through ADC.  ADC is just DVI with extra pins for power and USB, so all the device does is inject the necessary power and give you a USB and DVI cable on the ends.  No signal processing occurs in the device, and windows sees the display as a plain jane 17" digital flat panel.
Comment 1 Mike A. Harris 2005-03-18 01:12:53 EST
This bug report scrolls off the right side of the monitor 4 lengths.

Please file a new bug report, with right margin at 72 column or so for

Also, attach your X server config file and log file to the report.

Thanks in advance.
Comment 2 Mike A. Harris 2005-04-11 06:23:09 EDT

*** This bug has been marked as a duplicate of 151474 ***

Note You need to log in before you can comment on or make changes to this bug.