Bug 151474 - DVI panel loses sync when anaconda starts X with unknown monitor type.
DVI panel loses sync when anaconda starts X with unknown monitor type.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 150269 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 07:37 EST by Justin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 10:15:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2985 None None None Never

  None (edit)
Description Justin 2005-03-18 07:37:37 EST
+++ This bug was initially created as a clone of Bug #150269 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) 
Safari/125.12

Description of problem:

Basically I am using an Apple 17" LCD display with a Radeon 9000 on an older dual proc P3 box.  The
Radeon 9000 is detected, but the monitor type is set as "unknown", and as soon as it attempts to start
X, it shuts down the DVI output from the card and lights the analog one.  I tested it by connecting an
analog display after it kills the DVI display and it is sending signal to the analog vga output of the card
after that.  This is a real problem if, like me, you have a DVI-only monitor.  I had to hook up the VGA
input from my rear projector to confirm this problem, and then had to do the install from the ascii
installer.

Version-Release number of selected component (if applicable):
NOTE: I cannot attach X config or logs because the machine is unusable for me when it does this,
however, the x-config is whatever anaconda chooses during graphical installer boot for the radeon
9000 video card and the "Unknown" monitor type.

How reproducible:
Always

Steps to Reproduce:
1. Connect a DVI-only flat panel of a type unknown to FC3 to a Radeon 9000.
2. Boot from install CD, select graphical installation
3. On start of X, DVI panel will lose sync and analog VGA output on card will light.
    

Expected Results:  There should at least be an installer switch allowing this to be overridden. It should
be smart enough to detect that the unknown monitor it probed is connected to the DVI output of the
card.  If it drove the DVI port at 640x480 it would at least be possible to complete the graphical install.
This problem continues after installation, as Fedora boots into the GUI login screen and against de
-syncs the DVI port in favor of the analog VGA port.  It should have a configuration profile for detecting
Apple displays.

Additional info:

Note that I am using an Apple display that has the proprietary ADC connector on it, so I am using a
separate device to do power injection through ADC.  ADC is just DVI with extra pins for power and USB,
so all the device does is inject the necessary power and give you a USB and DVI cable on the ends.  No
signal processing occurs in the device, and Windows XP sees the display as a plain jane 17" digital flat
panel.
Comment 1 Mike A. Harris 2005-04-11 06:23:11 EDT
*** Bug 150269 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2005-04-11 06:27:04 EDT
We do not have this hardware available to attempt to reproduce this problem.

My suggestion for best results, is to report it directly to X.Org, which
will greatly increase the likelyhood of someone being able to attempt to
reproduce the issue and provide a fix sooner.

You can file an X.Org bug report by visiting:
    http://bugs.freedesktop.org

Once you have filed your bug report in X.org bugzilla, please paste the
URL here and we will track this issue in the X.Org bugzilla, and review
any fixes that become available for consideration in future Fedora Core
updates.
Comment 3 Mike A. Harris 2005-04-11 06:27:52 EDT
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 4 Justin 2005-04-11 22:12:20 EDT
Hopefully I submitted for thw right component.  Here is the link to the x.org bugzilla entry.

https://bugs.freedesktop.org/show_bug.cgi?id=2985
Comment 5 David Zeuthen 2005-04-11 22:28:05 EDT
Bug submitted to upstream bug tracker in comment 4 was against inappropriate
upstream product.
Comment 6 Mike A. Harris 2005-04-12 10:15:07 EDT
Thanks for reporting upstream Justin.  I corrected the upstream component
to "xorg" and reopened the bug, along with a request to supply the complete
details in the upstream report for X.Org developers.

We'll track the issue in the upstream bugzilla now.

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.