Bug 1502862 - Update storage-environment.yaml so that it defaults to ceph-ansible
Summary: Update storage-environment.yaml so that it defaults to ceph-ansible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 12.0 (Pike)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-16 20:59 UTC by John Fulton
Modified: 2018-02-05 19:15 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.3-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:15:46 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1724182 0 None None None 2017-10-17 09:44:46 UTC
OpenStack gerrit 512569 0 None None None 2017-10-17 09:50:12 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description John Fulton 2017-10-16 20:59:32 UTC
A containerized ceph deployment which didn't pass any overrides but used only the defaults found in: 

-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml 

Produced a resources.WorkflowTasks_Step2_Execution Heat resource whose Mistral ansible-playbook call did not pass the osd_scenario parameter to the ansible-playbook --extra-vars run [1]. This resulted in a overcloud deployment with 0 OSDs (0 OSD containers) though the deployment succeeded and evidence of the failure was not seen later until a tempest run. 

Though ceph-ansible should better handle this scenario and fail as per BZ 1502841 [2], the defaults alone should work, provided that the ceph overcloud node has the device /dev/vdb. 

[1] http://paste.openstack.org/show/623752 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1502841

Comment 4 Giulio Fidente 2017-10-17 09:42:12 UTC
Thanks John, as a side note, we might also default storage-environment.yaml to ceph-ansible at this point.

Comment 5 Giulio Fidente 2017-10-17 09:55:42 UTC
The root cause here is that /home/stack/virt/internal.yaml is overriding the default CephAnsibleDisksConfig passing only 'devices:', see [1]

Instead of closing this BZ though, we might use it to track migration of storage-environment.yaml from puppet-ceph to ceph-ansible if QE agrees with it being a good idea.

Yogev, Sasha, Marius, what do you guys think?

1. http://cougar11.scl.lab.tlv.redhat.com/phase1-12_director-rhel-7.4-virthost-1cont_1comp_1ceph-ipv4-vxlan-ceph-containers/125/undercloud-0.tar.gz?undercloud-0/home/stack/virt/internal.yaml

Comment 15 Yogev Rabl 2017-11-15 20:11:37 UTC
verified on openstack-tripleo-heat-templates-7.0.3-3.el7ost.noarch

Comment 18 errata-xmlrpc 2017-12-13 22:15:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.