Bug 1503344 - RFE: include CLI tooling for all providers that allow redistribution of said tools
Summary: RFE: include CLI tooling for all providers that allow redistribution of said ...
Keywords:
Status: CLOSED DUPLICATE of bug 1573658
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-17 22:10 UTC by Jeff Warnica
Modified: 2018-08-09 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 22:07:28 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Jeff Warnica 2017-10-17 22:10:36 UTC
Per summary, the CF appliances should ship with the CLI tooling for all the providers CFME supports... at least those licenses might allow. This would include, at least all the other RH products, OSP, OSE, RHV. 

As a consultant, I'm often not able to access the clients network directly, the provided access through a clean windows laptop, VDI, or such. Installing the clients can range from a pain to impossible. Regardless, the appliances presumably have firewall access and the cli makes an quick and easy testing tool vs anything else.

Comment 2 Alex Mayberry 2017-11-08 15:12:20 UTC
+1

Comment 3 Brandon Dunne 2018-08-09 22:07:28 UTC
Dependency problems: (RPMs, Python packages, Ruby Gems, Ansible modules, etc.)

Several of us on the platform team met recently to discuss dependency problems and came up with the following decisions:
- The appliance will carry dependencies for the application and any necessary debugging tools
- The application itself will declare all of its dependencies as it has in the past
- Application plugins will declare their dependencies in a way that the application / appliance build code can aggregate and install them
- Customer dependencies will need to be installed and maintained by customers since it is impossible for us to maintain and upgrade that list of dependencies.  We can not guarantee that any changes to these dependencies will not break scripts that are not maintained by the engineering team.

*** This bug has been marked as a duplicate of bug 1573658 ***


Note You need to log in before you can comment on or make changes to this bug.