Bug 1573658 - [RFE] Update savon gem to 2.12.0 [NEEDINFO]
Summary: [RFE] Update savon gem to 2.12.0
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
: 1503344 1514550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 21:30 UTC by David Luong
Modified: 2018-08-27 16:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 22:02:46 UTC
Category: Feature
Cloudforms Team: CFME Core
Target Upstream Version:
jsisul: needinfo? (gtanzill)


Attachments (Terms of Use)

Description David Luong 2018-05-01 21:30:45 UTC
1. Proposed title of this feature request
Update savon gem to 2.12.0

3. What is the nature and description of the request?
Update savon gem

4. Why does the customer need this? (List the business requirements here)
Would like to use SOAP call to create a folder in vCenter

5. How would the customer like to achieve this? (List the functional requirements here)
Update savon gem

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
Successful use of the savon gem to make a folder in vCenter

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
No

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
N/A

9. Is the sales team involved in this request and do they have any additional input?
No

10. List any affected packages or components.
savon gem

Comment 3 Brandon Dunne 2018-08-09 22:02:46 UTC
Dependency problems: (RPMs, Python packages, Ruby Gems, Ansible modules, etc.)

Several of us on the platform team met recently to discuss dependency problems and came up with the following decisions:
- The appliance will carry dependencies for the application and any necessary debugging tools
- The application itself will declare all of its dependencies as it has in the past
- Application plugins will declare their dependencies in a way that the application / appliance build code can aggregate and install them
- Customer dependencies will need to be installed and maintained by customers since it is impossible for us to maintain and upgrade that list of dependencies.  We can not guarantee that any changes to these dependencies will not break scripts that are not maintained by the engineering team.

In this particular case, the customer can install the version of the savon gem that works for their scripting using the `gem install` command.

Comment 4 Brandon Dunne 2018-08-09 22:05:22 UTC
*** Bug 1610768 has been marked as a duplicate of this bug. ***

Comment 5 Brandon Dunne 2018-08-09 22:06:03 UTC
*** Bug 1514550 has been marked as a duplicate of this bug. ***

Comment 6 Brandon Dunne 2018-08-09 22:07:28 UTC
*** Bug 1503344 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.