Bug 15045 - Norwegian keyboard in X - problems after installation
Summary: Norwegian keyboard in X - problems after installation
Status: CLOSED DUPLICATE of bug 16009
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-01 19:44 UTC by Inger Karin Haarbye
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 16:37:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config-file for XFree3 (15.38 KB, text/plain)
2000-10-05 20:38 UTC, Inger Karin Haarbye
no flags Details
Config-file for XFree4 (3.18 KB, text/plain)
2000-10-05 20:39 UTC, Inger Karin Haarbye
no flags Details

Description Inger Karin Haarbye 2000-08-01 19:44:51 UTC
I installed Pinstripe today. During installation I was asked to chose
keyboard. I didn't do much changes from the suggestions at all, and I tried
@ and ~.

After installation was finished and X started, I found out that @ and other
keys with "alt-gr" didn't work, and not "backspace either".

After running Xconfigurator it was OK! 

Xfree86 3.3.6 with Mach64

From XF86Config - Keyboard section (after Xconfigurator):

   XkbKeycodes     "xfree86"
   XkbTypes        "default"
   XkbCompat       "default"
   XkbSymbols      "us(pc101)"
   XkbGeometry     "pc"
   XkbRules        "xfree86"
   XkbModel        "pc101"
   XkbLayout       "no"

From XF86Config.save - keyboard section (before Xconfigurator):

     XkbRules    "xfree86"
     XkbModel    "pc102"
     XkbLayout   "no"
     XkbVariant  ""
     XkbOptions  ""

Comment 1 Michael Fulbright 2000-08-17 16:37:00 UTC
Could you verify these please Trond?

Comment 2 Trond Eivind Glomsrxd 2000-08-17 18:57:18 UTC
This is a duplicate of 16009 (actually, the other way round obviously...) which
has been solved. Works fine now - even dead keys work if you want to.

*** This bug has been marked as a duplicate of 16009 ***

Comment 3 Inger Karin Haarbye 2000-10-05 18:57:39 UTC
I have the same problem in final RH7 today. I have chosen norvegian install.
Starting X after installation - backspace and @ is noe working. (KDE). After
Xconfigurator it workes OK.  (XFree 3 and 4). 
Matrox Millennium G400 Max - this time.

Comment 4 Trond Eivind Glomsrxd 2000-10-05 19:00:17 UTC
Did you by any chance store the files which made it not work? Did it not work in
both XFree 4 and 3?

Comment 5 Inger Karin Haarbye 2000-10-05 20:38:31 UTC
Created attachment 3818 [details]
Config-file for XFree3

Comment 6 Inger Karin Haarbye 2000-10-05 20:39:22 UTC
Created attachment 3819 [details]
Config-file for XFree4

Comment 7 Inger Karin Haarbye 2000-10-05 20:41:24 UTC
After RH7-final install, X started with XFree3 - where the problem occurred.
After Xconfigurator, the problem was gone, but still XFree3. I wanted Xfree4,
and after Xconfigurator --preferxf4 everything was OK - with XFree4.
So - that means - I did not try XFree4 before Xconfigurator. But I have the
config-files, and I have tried later. Looks like the problem is only with the
XF86Config-file (for XFree3) - not with the XF86Config-4. 
Config-files as attachments.


Note You need to log in before you can comment on or make changes to this bug.