Bug 16009 - ALT key broken
Summary: ALT key broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
: 15045 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-11 17:24 UTC by Richard Allen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 16:21:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Allen 2000-08-11 17:24:44 UTC
The Icelandic keymap has a few important characters that need the ALT
modifyer.
the @ is a fine example of that.
To get the @ symbol, we press ALT-GR and Q (Some keymaps also accept ALT-GR
and 2).
Now it's like the alt key has no effect. This was OK in beta5 so what
changed ?

Comment 1 Glen Foster 2000-08-13 19:53:29 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Bill Nottingham 2000-08-14 19:07:44 UTC
Very very little. Can you confirm that the XFree86 config
file is correct?

Comment 3 Richard Allen 2000-08-14 20:11:18 UTC
Uh ?  It4s just as anaconda created it.    Which sections in XF86Config are you interested in ?

PS: even the pipe character need's the ALT key (|) :(



Comment 4 Bill Nottingham 2000-08-14 21:24:09 UTC
What does it have in the Keyboard section (for XFree3) or 
InputDevice section (for XFree4)?


Comment 5 Richard Allen 2000-08-14 22:59:01 UTC
Ok. Details are as follows (Sorry for not posting them immediatly.)

My box has a built in Matrox G200 that Im not using. It also has a PCI Voodoo3
3000. The installation went like a charm (whithout any hitches.)

in section keyboard in /etc/X11/XF86Config (comments removed):
Section "Keyboard"
    Protocol    "Standard"
    AutoRepeat  500 5
    LeftAlt         Meta
    RightAlt        Meta
    ScrollLock      Compose
    RightCtl        Control
     XkbRules    "xfree86"
     XkbModel    "pc102"
     XkbLayout   "is"     XkbVariant  "None"
     XkbOptions  ""
EndSection

in /etc/X11/XF86Config-4 (comments also removed)
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option  "XkbRules"      "xfree86"
        Option  "XkbModel"      "pc102"
        Option  "XkbLayout"     "is"
        Option  "XkbVariant"    "None"
        Option  "XkbOptions"    ""
EndSection

The only wierd thing IMHO is that I think it should be pc101 XkbModel.





Comment 6 Bill Nottingham 2000-08-14 23:06:32 UTC
If you change it to pc101, does it work?

(Sorry, we don't have any icelandic keyboards here
to test with. ;) )

Comment 7 Richard Allen 2000-08-14 23:29:12 UTC
No it had no effect.   Why do you need an Icelandic keyboard to test with ?  The
only difference between it and your standard US keyboard is whats printed on the
keys themselvs.
You can go into your XF86Config file, change "XkbLayout" to be "is" (not "us")
and try
pressing alt-gr (The alt key on the right of the space bar) and Q.  If you get
an @, the problem is fixed.  If not, we still have a problem.

If you want to see how it (the Icelandic keymap) works, switch to the console
and do:
"loadkeys is-latin1" and then press alt-q (The pipe char should be on ALT and
the key on the left side of the Z key)


Comment 8 Richard Allen 2000-08-15 10:55:44 UTC
I got the keymap file from a RedHat 6.1 (Cartman) system and placed it into
/usr/X11R6/lib/X11/xkb/symbols (filename "is") and restarted X.  No luck.


Comment 9 Richard Allen 2000-08-15 11:22:39 UTC
It's actually remarkable how hard life get's without the @ and | symbols :-)

(I had to search quite a bit for the | char in exsisting scripts to be able to
cut'n'paste it into this :-)



Comment 10 Preston Brown 2000-08-15 15:59:49 UTC
Trond, please investigate

Comment 11 Bill Nottingham 2000-08-15 16:06:16 UTC
XFree3 or XFree4 server (not that it should matter, but it might.)

Comment 12 Bill Nottingham 2000-08-15 16:21:11 UTC
Remove the 'Option "XkbVariant" "none"' and it should work.

Comment 13 Bill Nottingham 2000-08-15 16:29:47 UTC
(alternatively, change "none" to "".)

This just got fixed in anaconda five minutes ago. :)

Comment 14 Trond Eivind Glomsrxd 2000-08-15 19:02:40 UTC
This works with Norwegian dead-keys layout as well.

Comment 15 Trond Eivind Glomsrxd 2000-08-17 18:57:16 UTC
*** Bug 15045 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.