Bug 1504508 - tripleo-common hardcodes amd64 for overcloud-full images
Summary: tripleo-common hardcodes amd64 for overcloud-full images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: All
OS: Linux
medium
medium
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Tony Breeds
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: RHOS-13-ppc64le 1489476 1506507
TreeView+ depends on / blocked
 
Reported: 2017-10-20 04:16 UTC by Tony Breeds
Modified: 2018-06-27 13:38 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-common-8.2.1-0.20171206155029.bb2b96e.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 489476 None None None 2017-10-20 04:16:01 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:42 UTC

Description Tony Breeds 2017-10-20 04:16:01 UTC
When trying to build an overcloud image on ppc64le tripleo/DIB attempts to build an amd64 image.

openstack-tripleo-common-7.6.3-0.20171010234827.el7ost.noarch


Steps to Reproduce:
1. Create a ppc64le 'input image':
   https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14309272
2. Create a ppc64le 'utility image'
   https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14309274
3. Boot the utility image and import the input image from step 1
4. Use the TDL template from http://pkgs.devel.redhat.com/cgit/rpms/rhosp-director-images/tree/overcloud-full.tdl?h=rhos-12.0-rhel-7 to transform the simple input image into an overcloud image

Actual results:

openstack overcloud image builds fails with:

"""
Command '['disk-image-create', '-a', 'amd64', '-o', './overcloud-full', '-t', 'qcow2', '-p', 'python-psutil,python-debtcollector,plotnetcfg,sos,ntp,device-mapper-multipath,python-heat-agent-puppet,python-heat-agent-hiera,python-heat-agent-apply-config,python-heat-agent-ansible,python-heat-agent-docker-cmd,python-heat-agent-json-file,redhat-access-insights,rhosp-release', '--min-tmpfs', '5', 'rhel7', 'baremetal', 'dhcp-all-interfaces', 'overcloud-agent', 'overcloud-full', 'overcloud-controller', 'overcloud-compute', 'overcloud-ceph-storage', 'puppet-modules', 'os-net-config', 'stable-interface-names', 'grub2', 'element-manifest', 'dynamic-login', 'iptables', 'enable-packages-install', 'pip-and-virtualenv-override', 'dracut-regenerate', 'remove-machine-id']' returned non-zero exit status 1
"""

Expected results:

A generated overcloud image.


Additional info

The are a couple of options here
1. Backport https://review.openstack.org/#/c/489476/ to pike upstream and the import the new SHA into the RHOS packaging
2. use scripts in rhosp-director-images to do this translation.

Comment 12 Gurenko Alex 2018-06-07 12:10:43 UTC
[stack@undercloud-0 ~]$ rpm -q openstack-tripleo-common
openstack-tripleo-common-8.6.1-18.el7ost.noarch

Verified on puddle 2016-06-01.1

Comment 14 errata-xmlrpc 2018-06-27 13:37:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.