Bug 150458 - evolution addressbook (list-view) - cannot print CJKI
Summary: evolution addressbook (list-view) - cannot print CJKI
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libgal2   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic 156322 157394
TreeView+ depends on / blocked
 
Reported: 2005-03-07 07:24 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-556
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 14:44:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
calendar containing all 5 composed indic characters (9.72 KB, text/plain)
2005-03-07 07:24 UTC, Lawrence Lim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:556 qe-ready SHIPPED_LIVE evolution and libgal2 bug fix and enhancement update 2005-10-05 04:00:00 UTC

Description Lawrence Lim 2005-03-07 07:24:03 UTC
Description of problem:
Creating a new bug to track the progress of the porting libgal2 to the new API
following the fix of bug 138075.

Version-Release number of selected component (if applicable):
libgal2-2.2.3-4

How reproducible:
Always

Steps to Reproduce:
1.LANG=hi_IN.UTF-8
2.import the calendar.ics file attached
3.print the calendar in List View
  
Actual results:
Empty squares are printed

Expected results:
Able to print indic

Additional info:
Will tag to U2 blocker once available

Comment 1 Lawrence Lim 2005-03-07 07:24:03 UTC
Created attachment 111732 [details]
calendar containing all 5 composed indic characters

Comment 2 Lawrence Lim 2005-03-07 07:25:07 UTC
This is in the upstream bug tracker here:
http://bugzilla.ximian.com/show_bug.cgi?id=72815

Comment 4 Lawrence Lim 2005-03-08 01:00:14 UTC
Thanks Suzanne. :-)


Comment 5 Leon Ho 2005-04-11 06:36:03 UTC
Asked Lawrence it should only reflect to listview only. updating.

Comment 6 Lawrence Lim 2005-05-11 06:20:31 UTC
Am afraid that it affects more than Indic in the List View. Tried with the
following packages, all CJKI locales are affected.

evolution-webcal-2.2.0-1
evolution-2.2.2-5
evolution-data-server-1.2.2-2
evolution-devel-2.2.2-5
evolution-data-server-devel-1.2.2-2
evolution-connector-2.2.2-3
evolution-debuginfo-2.2.2-5

Comment 7 Lawrence Lim 2005-05-11 06:26:45 UTC
Oops. My bad, I got confused. Comment #6 was tested on FC4. Please refer to bug
157394

Comment 8 dff 2005-06-08 19:55:03 UTC
PM ACK.

Comment 14 Dave Malcolm 2005-07-29 04:19:28 UTC
Status report: Initial version of a fix built into rawhide as evolution-2.3.6-1,
however this doesn't work at the moment (pango printing seems to be broken;
should be fixed in next day or so in rawhide).  Code compiles and in theory
should work, but I may have messed up coordinate systems or introduced other
bugs; should be trivial to backport from rawhide to RHEL4 (code has barely
changed, and patch almost applies cleanly)

Comment 15 Dave Malcolm 2005-07-29 04:20:17 UTC
(note that in rawhide this code is now in the evolution package, and libgal2
will probably become obsolete; in rhel4 the code is in the libgal2 package)

Comment 16 Dave Malcolm 2005-08-02 00:38:49 UTC
Status report: fixed some bugs in my patch; am building evolution-2.3.6.1-3 with
latest ETable patch into rawhide.

Should (mostly) work, fixing this bug, but introduces a minor regression with
some headings (specifically with e_table_group_container_print_page); way to see
this regression is when doing a Print/Print Preview of Contacts when in View->By
Company mode.



Comment 17 Dave Malcolm 2005-08-02 20:56:32 UTC
Version in rawhide actually works; problem described in comment #16 was
appearing only in my CVS build, for some reason.

Comment 18 Dave Malcolm 2005-08-03 00:18:58 UTC
Built with patch for RHEL4 as libgal2-2.2.3-9

Comment 19 Red Hat Bugzilla 2005-10-05 14:44:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-556.html



Note You need to log in before you can comment on or make changes to this bug.