Bug 1505090 - In text installation mode,unable to continue installation without selecting any add-ons
Summary: In text installation mode,unable to continue installation without selecting a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Konecny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1505089 (view as bug list)
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-22 02:57 UTC by lnie
Modified: 2017-11-08 22:10 UTC (History)
12 users (show)

Fixed In Version: anaconda-27.20.4-3 anaconda-27.20.4-4.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-08 22:10:32 UTC


Attachments (Terms of Use)
anaconda.log (40.38 KB, text/plain)
2017-10-22 02:57 UTC, lnie
no flags Details
packaging.log (28.70 KB, text/plain)
2017-10-22 02:58 UTC, lnie
no flags Details
storage.log (61.42 KB, text/plain)
2017-10-22 02:59 UTC, lnie
no flags Details

Description lnie 2017-10-22 02:57:21 UTC
Description of problem:
After selecting Fedora Server Edition for source selection,anaconda keeps saying:
source changed-please verify,if you don't select any add-ons.If you choose one,
everything will be fine.

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-27-20171020.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2017-10-22 02:57:54 UTC
Created attachment 1341720 [details]
anaconda.log

Comment 2 lnie 2017-10-22 02:58:33 UTC
Created attachment 1341721 [details]
packaging.log

Comment 3 lnie 2017-10-22 02:59:02 UTC
Created attachment 1341722 [details]
storage.log

Comment 4 lnie 2017-10-23 08:50:55 UTC
Also see this in Fedora-Server-netinst-x86_64-27-20171020.n.0.iso,but not 
Fedora-Workstation-netinst-x86_64-27-20171020.n.0.iso

Comment 5 lnie 2017-10-23 08:52:51 UTC
*** Bug 1505089 has been marked as a duplicate of this bug. ***

Comment 6 Jiri Konecny 2017-10-25 07:50:25 UTC
I'm not able to reproduce this. Based on logs it looks to me like there was a temporal issue in the compose or packages.

Could you please re-test this on a newer iso.

Comment 7 lnie 2017-10-25 13:51:23 UTC
I have tested with the latest Fedora-Server-dvd-x86_64-27-20171023.n.0.iso and 
Fedora-Server-netinst-x86_64-27-20171023.n.0.iso.The dvd image is better now,
anaconda choose Fedora server edition for you,everything will be fine if you choose CD/DVD for installation source.But you will see this bug if you choose network for installation source.The netinst image is still there.
These means you are unable to use network installation for both of the installations.

Comment 8 Fedora Blocker Bugs Application 2017-10-26 02:47:07 UTC
Proposed as a Blocker for 27-final by Fedora user lnie using the blocker tracking app because:

 This looks like affects the final criteria:
The installer must be able to complete an installation using all supported interfaces.

Comment 9 Jiri Konecny 2017-10-26 09:59:12 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1226

Comment 10 Jiri Konecny 2017-10-26 10:01:59 UTC
To clarify the reproducer. This is happening when you select exactly the same software selection what was set before installation source changed.

In this case the "Fedora Server Edition" environment without addons selected is the default setting for Fedora server DVD installation.

Comment 11 Adam Williamson 2017-10-26 20:01:47 UTC
Discussed at 2017-10-26 Fedora 27 Final go/no-go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-10-26/f27-final-and-server-beta-go-no-go-meeting.2017-10-26-17.00.html . Rejected as a blocker, as the bug doesn't really infringe any of the release criteria as we understand it - it only happens after changing the source, in text mode, and can be worked around by tweaking the package selection then tweaking it back. Accepted as a freeze exception, as it's a sub-optimal behaviour in the installer that we can't fix with an update and the fix seems fairly safe.

Comment 12 Adam Williamson 2017-10-28 01:52:25 UTC
Jiri, Martin - can you guys please do a build and update ASAP? I asked Martin on IRC last night but I guess he missed the message.

Comment 13 Fedora Update System 2017-10-30 16:02:44 UTC
anaconda-27.20.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 14 Fedora Update System 2017-10-31 19:09:32 UTC
anaconda-27.20.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 15 Fedora Update System 2017-11-02 20:50:56 UTC
anaconda-27.20.4-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 16 Fedora Update System 2017-11-04 18:01:23 UTC
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 17 Fedora Update System 2017-11-08 22:10:32 UTC
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.