Bug 150528 - ui compiler segfaults
ui compiler segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Waiting for glibc fix.
:
: 151183 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 17:58 EST by Vladimir Kondratiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 03:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kondratiev 2005-03-07 17:58:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1

Description of problem:
While rebuilding RPM for esvn 0.6.9 (from
http://esvn.umputun.com/esvn-0.6.9-1.src.rpm),
ui segfaults.

Even if .ui file that was compiled, is incorrect, 'ui' should provide
error message but not segfault.

Version-Release number of selected component (if applicable):
qt-3.3.4-9

How reproducible:
Always

Steps to Reproduce:
1. cd /tmp && wget http://esvn.umputun.com/esvn-0.6.9-1.src.rpm
2. rpmbuild --rebuild esvn-0.6.9-1.src.rpm


Actual Results:  ui segfaults (just last few lines):
g++ -c -pipe -Wall -W -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32
-march=i386 -mtune=pentium4  -DVERSION=\"0.6.9\" -DQT_NO_DEBUG
-DQT_SHARED -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.3/mkspecs/default -I.
-I/usr/lib/qt-3.3/include -I.ui/ -I.ui -I.moc/ -o .obj/check_lbi.o
src/check_lbi.cpp
g++ -c -pipe -Wall -W -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32
-march=i386 -mtune=pentium4  -DVERSION=\"0.6.9\" -DQT_NO_DEBUG
-DQT_SHARED -DQT_THREAD_SUPPORT -I/usr/lib/qt-3.3/mkspecs/default -I.
-I/usr/lib/qt-3.3/include -I.ui/ -I.ui -I.moc/ -o .obj/commitwindow.o
src/commitwindow.cpp
/usr/lib/qt-3.3/bin/uic .ui/frm_main.ui -i frm_main.h -o .ui/frm_main.cpp
make[1]: *** [.ui/frm_main.cpp] Segmentation fault
make[1]: *** Deleting file `.ui/frm_main.cpp'
make[1]: Leaving directory `/home/vkondra-l/rpm-top/BUILD/esvn'
make: *** [esvn] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.27799 (%build)


RPM build errors:
    user evgb does not exist - using root
    group evgb does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.27799 (%build)


Expected Results:  compilation went OK

Additional info:
Comment 1 Ngo Than 2005-03-09 05:11:06 EST
it seems a bug in kdelibs (libkdeui), which caused the Segmentation fault.
Comment 2 Petr Rockai 2005-03-09 05:25:34 EST
Assigning to self. 
Comment 3 Petr Rockai 2005-03-18 01:54:32 EST
Was tracked down to a possible glibc bug. I suggest using -nounload switch 
with uic in the meantime, as it remedies the problem. It is an workaround for 
the long-problematic library unmapping code within glibc. 
Comment 4 Ngo Than 2005-03-18 10:41:01 EST
*** Bug 151183 has been marked as a duplicate of this bug. ***
Comment 5 Ville Skyttä 2005-03-18 11:37:52 EST
Happened also when building qascade from Extras, -nounload worked around it.
Comment 6 Vladimir Kondratiev 2005-03-20 03:25:59 EST
I confirm -nounload works.
I modified QMAKE_UIC line in /usr/lib/qt-3.3/mkspecs/default/qmake.conf to
QMAKE_UIC		= $(QTDIR)/bin/uic -nounload
till glibc fix, this should fix this issue
Comment 7 Ngo Than 2005-03-21 03:55:54 EST
it's fixed in glibc-2.3.4-16, which should be available in rawhide now.
Comment 8 Ville Skyttä 2005-03-21 14:43:13 EST
Yep, at least qascade seems to build fine without -nounload to uic now.  Thanks.
Comment 9 Vladimir Kondratiev 2005-03-22 03:10:18 EST
My case get fixed too.

Note You need to log in before you can comment on or make changes to this bug.