Bug 150592 - up2date kernel - no module lpfc found for kernel - aborting
up2date kernel - no module lpfc found for kernel - aborting
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 15:09 EST by Lance A. Brown
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 18:15:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lance A. Brown 2005-03-08 15:09:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3

Description of problem:
I have a Dell PowerEdge 2450 with an Emulex Corporation LP9000 Fibre Channel Host Adapter installed using drivers downloaded from emulex.

Upgrading the kernel using 'up2date -u' resulted in a non-bootable system after the install of the kernel-smp RPM failed to create a proper initrd image or update /boot/grub/grub.conf properly.



Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-27.0.2.EL

How reproducible:
Always

Steps to Reproduce:
1. Install LP9000 card
2. Install lpfc driver per instructions included with package
3. Upgrade to current RHEL3 kernel using 'up2date -u'
4. Script failes because lpfc driver is not available in new kernel
5. kernel is installed, but /boot/grub/grub.conf is improperly updated.
  

Actual Results:  System is not bootable.  Grub comes up, but the only kernel available does not boot because its initrd image is missing.

Expected Results:  Old kernel entries in grub.conf should not have been deleted.
Old kernel RPM should not have been removed after failure of install scripts for new kernel RPM.

Additional info:
Comment 1 Lance A. Brown 2005-03-08 15:10:07 EST
Forgot to add this.  This appears to be the same problem, with a different
module, as bug #149120 "up2date kernel - No module ieee1394 found for kernel -
aborting"
Comment 2 Ernie Petrides 2005-03-08 16:41:08 EST
Hello, Lance.  I'm not sure why you are trying to use an externally
built lpfc driver, since RHEL3 contains a supported (internal) driver
since U4.  Does the RHEL3 driver work okay for you?
Comment 3 Lance A. Brown 2005-03-08 18:05:10 EST
Teach me to not read the release notes closely....
I was using the 'lpfcdd' driver from emulex because the RH-provided kernels
didn't have support.  Changing to the 'lpfc' driver let me get things working
without the emulex-provided driver.
Comment 4 Ernie Petrides 2005-03-08 18:15:26 EST
Excellent.  Thanks for the update, Lance.  I'll close this BZ for now as
WORKSFORME.  But if you have further problems, feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.