Bug 1506749 - Kernel 4.13.5-100.fc25.i686 (module) create artifact on screen
Summary: Kernel 4.13.5-100.fc25.i686 (module) create artifact on screen
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: x86Tracker
TreeView+ depends on / blocked
 
Reported: 2017-10-26 17:34 UTC by Alberto Chiodi
Modified: 2017-12-12 10:05 UTC (History)
20 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-12-12 10:05:10 UTC


Attachments (Terms of Use)
dmesg file in oops directory (73.79 KB, text/plain)
2017-10-26 17:34 UTC, Alberto Chiodi
no flags Details
Imagine of my screen after booting (381.71 KB, image/jpeg)
2017-11-04 18:43 UTC, Alberto Chiodi
no flags Details

Description Alberto Chiodi 2017-10-26 17:34:11 UTC
Created attachment 1343883 [details]
dmesg file in oops directory

Description of problem:

Preamble:
1) It may not be a bug but a disposal hardware management
2) from abrt files perhaps problem is in xorg-x11-drv-intel
(note: abrt tells me that it’s unable to produce report.
This report data from its files in “oops” directory)

Start eeepc and after few line of messages (I use pc with GRUB_CMDLINE_LINUX="rhgb quiet") graphics card products only artifacts on screen.
I cannot loggin in session, only reboot.
Note:
When I restart pc with older kernel (4.12.13-200) it’s work, but after I logging in session system produce messages about modified initrams 4.12.13-200.
I have to proceed with a “dracut -f” command in /boot directory for restoring system functionality (with older kernel) without alarm messages

Version-Release number of selected component (if applicable):

ASUS Eee PC 901 - 8.9" - Atom N270 - 1 GB RAM - 20 GB SSD
CPU  Intel Atom N270 / 1.6 GHz
Cache L2 - 512 KB 
Data Bus Speed 533 MHz 
Chipset Type Mobile Intel 945GSE Express 
abrt version  2.9.0
architecture i686
kernel 4.13.5-100.fc25.i686

How reproducible:

Everytime you switch on pc

Actual results:

It seems that kernel is working but, at the end of charging os, on screen there is only artifacts and it’s impossible logging in session.

Expected results:

Logging in session

Additional info:

Backtrace:
WARNING: CPU: 1 PID: 94 at drivers/gpu/drm/i915/intel_display.c:1252 assert_planes_disabled+0x11e/0x140 [i915]
Modules linked in: i915 i2c_algo_bit drm_kms_helper ata_generic syscopyarea serio_raw uas usb_storage pata_acpi sysfillrect atl1e sysimgblt fb_sys_fops drm video
CPU: 1 PID: 94 Comm: kworker/u4:2 Tainted: G        W       4.13.5-100.fc25.i686 #1
Hardware name: ASUSTeK Computer INC. 901/901, BIOS 2103    06/11/2009
Workqueue: events_unbound async_run_entry_fn
task: f40d8000 task.stack: f418c000
EIP: assert_planes_disabled+0x11e/0x140 [i915]
EFLAGS: 00010202 CPU: 1
EAX: 00000046 EBX: f6960000 ECX: ca29a4e4 EDX: 00000002
ESI: 00000042 EDI: 00000001 EBP: f418db1c ESP: f418db00
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
CR0: 80050033 CR2: f8406048 CR3: 34276000 CR4: 000006d0
Call Trace:

Components: xorg-x11-drv-intel

proc modules:

sunrpc 286720 1 - Live 0xf81d5000
uvcvideo 77824 0 - Live 0xf81bb000
videobuf2_vmalloc 16384 1 uvcvideo, Live 0xf81a6000
videobuf2_memops 16384 1 videobuf2_vmalloc, Live 0xf816e000
videobuf2_v4l2 20480 1 uvcvideo, Live 0xf8117000
videobuf2_core 36864 2 uvcvideo,videobuf2_v4l2, Live 0xf81b1000
videodev 151552 3 uvcvideo,videobuf2_v4l2,videobuf2_core, Live 0xf8180000
iTCO_wdt 16384 0 - Live 0xf8152000
media 32768 2 uvcvideo,videodev, Live 0xf8177000
iTCO_vendor_support 16384 1 iTCO_wdt, Live 0xf80e8000
snd_hda_codec_realtek 86016 1 - Live 0xf8158000
snd_hda_codec_generic 69632 1 snd_hda_codec_realtek, Live 0xf8140000
snd_hda_intel 36864 1 - Live 0xf80fc000
snd_hda_codec 106496 3 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel, Live 0xf8125000
coretemp 16384 0 - Live 0xf80bb000
joydev 20480 0 - Live 0xf811f000
snd_hda_core 65536 4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec, Live 0xf8106000
snd_hwdep 16384 1 snd_hda_codec, Live 0xf7fcd000
snd_seq 57344 0 - Live 0xf80ed000
lpc_ich 24576 0 - Live 0xf80e1000
snd_seq_device 16384 1 snd_seq, Live 0xf7fb2000
i2c_i801 24576 0 - Live 0xf7fc6000
snd_pcm 90112 3 snd_hda_intel,snd_hda_codec,snd_hda_core, Live 0xf80a4000
snd_timer 28672 2 snd_seq,snd_pcm, Live 0xf7fb9000
snd 69632 11 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer, Live 0xf7fa0000
soundcore 16384 1 snd, Live 0xf7f90000
eeepc_laptop 20480 0 - Live 0xf7f86000
sparse_keymap 16384 1 eeepc_laptop, Live 0xf7fc1000
rfkill 24576 2 eeepc_laptop, Live 0xf7f96000
acpi_cpufreq 20480 0 - Live 0xf7f80000
binfmt_misc 20480 1 - Live 0xf7f77000
i915 1437696 1 - Live 0xf8252000
i2c_algo_bit 16384 1 i915, Live 0xf8074000
drm_kms_helper 139264 1 i915, Live 0xf8081000
ata_generic 16384 0 - Live 0xf806f000
syscopyarea 16384 1 drm_kms_helper, Live 0xf807c000
serio_raw 16384 0 - Live 0xf8067000
uas 20480 0 - Live 0xf7fed000
usb_storage 53248 2 uas, Live 0xf8059000
pata_acpi 16384 0 - Live 0xf8051000
sysfillrect 16384 1 drm_kms_helper, Live 0xf804a000
atl1e 36864 0 - Live 0xf8040000
sysimgblt 16384 1 drm_kms_helper, Live 0xf7fe8000
fb_sys_fops 16384 1 drm_kms_helper, Live 0xf7fe1000
drm 303104 3 i915,drm_kms_helper, Live 0xf7ff5000
video 40960 2 eeepc_laptop,i915, Live 0xf7fd6000

reason:

WARNING: CPU: 1 PID: 94 at drivers/gpu/drm/i915/intel_display.c:1252 assert_planes_disabled+0x11e/0x140 [i915]

dmesg:

see attachment

lightdm.log.old file

[+0.24s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.24s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=816
[+0.24s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.24s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.24s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.24s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.24s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.24s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.25s] DEBUG: Registered seat module xlocal
[+0.25s] DEBUG: Registered seat module xremote
[+0.25s] DEBUG: Registered seat module unity
[+0.30s] DEBUG: Monitoring logind for seats
[+0.30s] DEBUG: New seat added from logind: seat0
[+0.30s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.30s] DEBUG: Seat seat0: Starting
[+0.30s] DEBUG: Seat seat0: Creating greeter session
[+0.50s] DEBUG: Seat seat0: Creating display server of type x
[+0.57s] DEBUG: Using VT 1
[+0.57s] DEBUG: Seat seat0: Starting local X display on VT 1
[+0.57s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.57s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.57s] DEBUG: DisplayServer x-0: Launching X Server
[+0.58s] DEBUG: Launching process 837: /usr/bin/X -background none  :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
[+0.58s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.58s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.58s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.78s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.78s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+4.64s] DEBUG: Got signal 10 from process 837
[+4.64s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+4.64s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+4.68s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+4.68s] DEBUG: Session pid=938: Started with service 'lightdm-greeter', username 'lightdm'
[+4.81s] DEBUG: Session pid=938: Authentication complete with return value 0: Success
[+4.81s] DEBUG: Seat seat0: Session authenticated, running command
[+4.81s] DEBUG: Session pid=938: Running command /usr/sbin/lightdm-gtk-greeter
[+4.81s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+4.81s] DEBUG: Session pid=938: Logging to /var/log/lightdm/seat0-greeter.log
[+6.59s] DEBUG: Activating VT 1
[+6.59s] DEBUG: Activating login1 session c1
[+9.74s] DEBUG: Greeter connected version=1.18.3 resettable=false
[+12.92s] DEBUG: Greeter start authentication for alberto
[+12.92s] DEBUG: Session pid=1117: Started with service 'lightdm', username 'alberto'
[+13.18s] DEBUG: Session pid=1117: Got 1 message(s) from PAM
[+13.18s] DEBUG: Prompt greeter with 1 message(s)
[+22.54s] DEBUG: Session pid=938: Terminated with signal 1
[+22.54s] DEBUG: Seat seat0: Session stopped
[+22.54s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+22.54s] DEBUG: Seat seat0: Stopping
[+22.54s] DEBUG: Seat seat0: Stopping display server
[+22.54s] DEBUG: Sending signal 15 to process 837
[+22.55s] DEBUG: Seat seat0: Stopping session
[+22.55s] DEBUG: Session pid=1117: Sending SIGTERM
[+22.55s] DEBUG: Session pid=1117: Terminated with signal 15
[+22.55s] DEBUG: Session: Failed during authentication
[+22.55s] DEBUG: Seat seat0: Session stopped
[+22.56s] DEBUG: Got signal 15 from process 1
[+22.56s] DEBUG: Caught Terminated signal, shutting down
[+22.56s] DEBUG: Stopping display manager
[+23.08s] DEBUG: Process 837 exited with return value 0
[+23.08s] DEBUG: DisplayServer x-0: X server stopped
[+23.08s] DEBUG: Releasing VT 1
[+23.08s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+23.08s] DEBUG: Seat seat0: Display server stopped
[+23.08s] DEBUG: Seat seat0: Stopped
[+23.08s] DEBUG: Display manager stopped
[+23.08s] DEBUG: Stopping daemon
[+23.09s] DEBUG: Exiting with return value 0

Comment 1 Alberto Chiodi 2017-10-29 17:03:29 UTC
Can it help?

https://patchwork.kernel.org/patch/2658481/

Hi

Alberto Chiodi

Comment 2 Alberto Chiodi 2017-11-03 06:58:35 UTC
kernel 4.13.8-100

The same thing

Comment 3 Jeff Backus 2017-11-04 14:36:56 UTC
Hi Alberto,

What was the last version of the kernel that worked for you?

Comment 4 Jeff Backus 2017-11-04 15:01:10 UTC
Looks like this may be related to issues:
* bug 1438258
* bug 1498725
* bug 1507055

Comment 5 Alberto Chiodi 2017-11-04 17:52:29 UTC
(In reply to Jeff Backus from comment #3)
> Hi Alberto,
> 
> What was the last version of the kernel that worked for you?

kernel 4.12.13-200
Hi
Alberto

Comment 6 Alberto Chiodi 2017-11-04 18:43 UTC
Created attachment 1347839 [details]
Imagine of my screen after booting

Confirm relation with other bugs reported by Jeff Backus
My computer begins its boot.
After few line left part of the screen products artifacts and right is black.
At the end of the boot this is the screen.
I discovered that if I digit my password I can open my session but only right part of the screen present background image; left part of the screen remain the same.
No mouse is visible on the screen also I think it's working.
I can only switch off pressing on/off button.
Perhaps menu's working but I don't see it
Hy
Alberto

Comment 7 Fedora End Of Life 2017-11-16 19:26:39 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2017-12-12 10:05:10 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.