Bug 150763 - Kernel compiled with gcc 4 gives network errors
Summary: Kernel compiled with gcc 4 gives network errors
Status: CLOSED DUPLICATE of bug 150567
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-10 11:56 UTC by Alfred Glanzer
Modified: 2015-01-04 22:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 19:06:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alfred Glanzer 2005-03-10 11:56:57 UTC
Compiling kernel-2.6.11-1.1177 on an FC4 machine (gcc 4.0.0,
kernel-2.6.11-1.1170) makes all network communication impossible,
except for the local network traffic!!!

The same kernel compiled on a FC3 machine (gcc 3.4.2,
kernel-2.6.11-1.1170) gives no problems.

Machine: small barebone with SIS chipset.

DMESG shows only trivial differences, the LSMOD-list is exactly the same.

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.1177

Actual Results:  Starting network gives error:
RTNETLINK answers: invalid argument

Comment 1 taj 2005-03-10 12:50:18 UTC
I noticed this too.  I just switched from compiling with gcc 3.4 to
4.0 and started getting the same messages.

route add default gw xxx.xxx.xxx.xxx

was all that was required after the above.

Comment 2 Alfred Glanzer 2005-03-10 12:59:03 UTC
Thanks for the info. It must be an ifup-problem, but how this is
related to gcc 4.0 is unclear for me.

Till solved, I will stick to the kernel - gcc 3.4.2 combi !



Comment 3 Dave Jones 2005-03-10 19:06:39 UTC

*** This bug has been marked as a duplicate of 150567 ***


Note You need to log in before you can comment on or make changes to this bug.