Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1507813 - telepathy-glib require rebuild against new glib2
telepathy-glib require rebuild against new glib2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: telepathy-glib (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
: Rebase
Depends On: 1507467
Blocks: 1505747
  Show dependency treegraph
 
Reported: 2017-10-31 04:43 EDT by Tomas Pelka
Modified: 2018-05-17 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: telepathy-glib-0.24.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:06:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:07 EDT

  None (edit)
Description Tomas Pelka 2017-10-31 04:43:26 EDT
Description of problem:
We did rebased glib2 to 2.54 due to mutter 3.26, we need to rebuild telepathy-glib against it too othervise gnome-shell won't start properly.

Version-Release number of selected component (if applicable):
telepathy-glib-0.24.0-1.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Oct 30 09:33:02 localhost.localdomain gnome-shell[15854]: JS ERROR: Error: Could not find definition of virtual function observe_channels
                                                          defineGObjectLegacyObjects/GObjectMeta<._init/<@resource:///org/gnome/gjs/modules/_legacy.js:482:25
                                                          defineGObjectLegacyObjects/GObjectMeta<._init@resource:///org/gnome/gjs/modules/_legacy.js:472:13
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          defineGObjectLegacyObjects/GObjectMeta<._construct@resource:///org/gnome/gjs/modules/_legacy.js:543:13
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/_legacy.js:117:20
                                                          Class@resource:///org/gnome/gjs/modules/_legacy.js:65:30
                                                          @resource:///org/gnome/shell/ui/components/telepathyClient.js:116:33
                                                          ComponentManager<._importComponent@resource:///org/gnome/shell/ui/components/__init__.js:35:13
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          ComponentManager<._ensureComponent@resource:///org/gnome/shell/ui/components/__init__.js:47:27
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          ComponentManager<._enableComponent@resource:///org/gnome/shell/ui/components/__init__.js:54:25
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          ComponentManager<._sessionUpdated/<@resource:///org/gnome/shell/ui/components/__init__.js:22:13
                                                          ComponentManager<._sessionUpdated@resource:///org/gnome/shell/ui/components/__init__.js:19:9
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          ComponentManager<._init@resource:///org/gnome/shell/ui/components/__init__.js:13:9
                                                          wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                          _Base.prototype._construct@resource:///org/gnome/gjs/modules/_legacy.js:18:5
                                                          Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/_legacy.js:117:20
                                                          _initializeUI@resource:///org/gnome/shell/ui/main.js:176:24
                                                          start@resource:///org/gnome/shell/ui/main.js:126:5
                                                          @<main>:1:31
Oct 30 09:33:02 localhost.localdomain gnome-shell[15854]: Execution of main.js threw exception: JS_EvaluateScript() failed
Oct 30 09:33:02 localhost.localdomain gnome-session-binary[15516]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Oct 30 09:33:02 localhost.localdomain gnome-session[15516]: gnome-session-binary[15516]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1

Expected results:


Additional info:
Comment 2 Tomas Pelka 2017-10-31 05:11:08 EDT
Oh and just note that after rebuild locally these errors are gone.
Comment 4 Debarshi Ray 2017-10-31 11:28:59 EDT
Thanks for the build, Kalev.

However, I am still curious how a glib2 update can break telepathy-glib like this. I see that we didn't update gobject-introspection so far for RHEL 7.5, but we did update gjs.
Comment 5 Kalev Lember 2017-10-31 11:31:34 EDT
I don't know. I had the same question on irc and rtcm said:

10:13 < kalev> weird that it needs a rebuild though, I wonder if we've somehow broken glib ABI or something?
10:23 < rtcm> kalev: I think telepathy needs to be rebuilt with a newer gobject-introspection so that the new shell JS implementation which inherits from telepathy gobjects works
Comment 9 errata-xmlrpc 2018-04-10 09:06:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.