Bug 1505747 - rebase gjs to 1.50
rebase gjs to 1.50
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gjs (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
Desktop QE
: Rebase
Depends On: 1507813 1510876
Blocks: 1481381
  Show dependency treegraph
 
Reported: 2017-10-24 04:31 EDT by Tomas Pelka
Modified: 2018-05-17 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: gjs-1.50.2-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal.log (857.27 KB, text/plain)
2017-10-30 05:11 EDT, Tomas Pelka
no flags Details
screenshot (211.98 KB, image/png)
2017-10-30 05:15 EDT, Tomas Pelka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:05 EDT

  None (edit)
Description Tomas Pelka 2017-10-24 04:31:36 EDT
rebase gjs to 1.47
Comment 1 Tomas Pelka 2017-10-26 02:22:52 EDT
(In reply to Tomas Pelka from comment #0)
> rebase gjs to 1.47

We should do rather 1.50 as 3.26 gnome-shell wont work with 1.47.
Comment 7 Tomas Pelka 2017-10-30 05:11 EDT
Created attachment 1345347 [details]
journal.log

Ok this is not good even with new cogl, clutter clutter-gtk.

Attaching journactl and will attach screenshot.
Comment 8 Tomas Pelka 2017-10-30 05:15 EDT
Created attachment 1345350 [details]
screenshot

Just point out that even gdm is not staring, it starts when I update cogl/clutter/clutter-gtk/gjs from COPR.

After gdm start and one trie to start session, than see the screenshot
Comment 9 Tomas Pelka 2017-10-30 05:37:44 EDT
Finally found config that works

cogl-1.22.2-6.1.el7_4.x86_64
clutter-1.26.2-3.1.el7_4.x86_64
clutter-gtk-1.8.4-1.el7_4.x86_64
gjs-1.50.0-1.el7_4.x86_64
mozjs52-52.3.0-1.el7_4.x86_64

Other pkgs are from RHEL (Brew)
Comment 10 Tomas Pelka 2017-10-30 09:41:22 EDT
I'm afraid we would need 1.50 gjs, Kalev should be on it now.
Comment 11 Kalev Lember 2017-10-30 19:57:11 EDT
1.50.1 build with bundled mozjs52 is under way: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14424097
Comment 13 Tomas Pelka 2017-10-31 04:45:03 EDT
Well with 1.50 it was still broken, which was weird. So Vlad (thanks vbenes!) had an idea that due to following error

 Oct 30 09:33:02 localhost.localdomain gnome-shell[15854]: JS ERROR: Error: Could not find definition of virtual function observe_channels

still appears in journactl we might need to rebuild telepathy-glib against new glib2-2.54 that we introduced as dep for mutter might help. And guess what it helped.

So I'm going to ask richi to rebuild telepathy and also I'm going to try downgrade to gjs-1.47 to avoid bundling mozjs52 into newer gjs. Unless you think it is beneficial to have new gjs in rhel7.

-Tom
Comment 14 Kalev Lember 2017-10-31 04:57:34 EDT
I'd feel much more confident shipping 1.50 than 1.47, as 1.47.0 is a development snapshot and not a final stable release. Also, gjs 1.50 together with gnome-shell 3.26 is the combination we shipped in F27 and known to work well.
Comment 15 Tomas Pelka 2017-10-31 05:01:28 EDT
(In reply to Tomas Pelka from comment #13)
> Well with 1.50 it was still broken, which was weird. So Vlad (thanks
> vbenes!) had an idea that due to following error
> 
>  Oct 30 09:33:02 localhost.localdomain gnome-shell[15854]: JS ERROR: Error:
> Could not find definition of virtual function observe_channels
> 
> still appears in journactl we might need to rebuild telepathy-glib against
> new glib2-2.54 that we introduced as dep for mutter might help. And guess
> what it helped.
> 
> So I'm going to ask richi to rebuild telepathy and also I'm going to try
> downgrade to gjs-1.47 to avoid bundling mozjs52 into newer gjs. Unless you
> think it is beneficial to have new gjs in rhel7.
> 
> -Tom

OK with gjs-1.47 gdm wont start, so your work Kalev was not useless. So I guess we will keep 1.50 version. Regarding "unbundling" mozjs52 I would propose to open new bugs for including it as standalone rpm in 7.6 and also updating gjs to use this system version instead of the bundled on in 7.6 too. What do you think?
Comment 16 Kalev Lember 2017-10-31 05:09:43 EDT
Sure, I think that's a good plan, but I'd wait a little bit with 7.6 bugs until we know what version of gnome-shell/gjs we'll be shipping there. It could be that we'll end up shipping a newer gjs version that needs even newer mozjs than mozjs52.

But if it's at all possible at this point to get mozjs52 into 7.5 I'd like that very much to clean things up a bit.
Comment 20 errata-xmlrpc 2018-04-10 09:04:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.