Bug 1508169 - incremental update of content-view added errata RHSA-2017:2998 packages and also added some other packages as well , which is not present in errata
Summary: incremental update of content-view added errata RHSA-2017:2998 packages and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.2.9
Hardware: All
OS: Linux
high
high with 4 votes vote
Target Milestone: Released
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
: 1515752 1516478 1566755 1640420 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-31 23:58 UTC by asamad
Modified: 2019-10-07 17:19 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:36:38 UTC


Attachments (Terms of Use)
verification screenshot (61.21 KB, image/png)
2019-02-12 20:53 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:36:49 UTC
Pulp Redmine 2478 Normal CLOSED - CURRENTRELEASE Support more conservative dependency solving 2018-09-18 18:05:07 UTC

Description asamad 2017-10-31 23:58:17 UTC
Description of problem: publishing incremental content-view the errata RHSA-2017:2998, relevant pkg's are getting added as well as more packages also  gets added which might be the dependencies 


Version-Release number of selected component (if applicable):6.2.9


How reproducible:


Steps to Reproduce:

1.Satellite 6.2.9
2.content-view version list --organization-id=1
3.erratum list -->> Select errata-id which need to be added to content-view.
4.command to publish incremental -->>#hammer content-view version incremental-update --errata-ids RHSA-2017:2988 --content-view-version-id=17 --organization-id=1


Actual results: able to see packages of relevant errata in the incremental published content-view as well as extra packages like bash,nss,ncurses* etc. 


Expected results: only Java packages should be visible in published content-view version Packages Tab not all.



Additional info: Client registered with the incremental content-view is able to install java package successfully, But failing on dependencies issues with bash,nss,ncurses* packages.

Comment 2 asamad 2017-11-14 17:08:44 UTC
Hello Brad,

Nope as the client is facing this issue might be because of dependencies for the client in which he is trying to update the errata.

As we tried to update other errata which is working fine without dependencies similarly if we update errata RHSA-2017:2988 it also gets packages  bash,nss,ncurses* etc.

Comment 3 Brad Buckingham 2017-12-01 13:56:20 UTC
*** Bug 1515752 has been marked as a duplicate of this bug. ***

Comment 6 Justin Sherrill 2017-12-18 15:41:05 UTC
*** Bug 1516478 has been marked as a duplicate of this bug. ***

Comment 11 Brad Buckingham 2018-04-20 17:33:42 UTC
*** Bug 1566755 has been marked as a duplicate of this bug. ***

Comment 12 pulp-infra@redhat.com 2018-04-20 18:04:42 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 13 pulp-infra@redhat.com 2018-04-20 18:04:47 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 14 pulp-infra@redhat.com 2018-06-27 13:07:22 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2018-07-17 12:36:24 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 16 pulp-infra@redhat.com 2018-07-17 13:06:04 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 18 pulp-infra@redhat.com 2018-09-18 18:05:08 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 21 jcallaha 2019-02-12 20:52:52 UTC
Verified in Satellite 6.5.0 Snap 15

Created a new content view
Added RHEL 7 Extras Repo
Created a filter to only include buildah versions less than 1.3
Publish
See attached screenshot for the only packages in this version
Performed an incremental update with an Errata that only required buildah to be v1.2

-bash-4.2# hammer content-view version incremental-update --content-view-version-id 19 --errata-ids RHEA-2018:3365
[.....................................................................................................................................................................................] [100%]
Content View: base version 4.1
Added Content:
  Errata:
        RHEA-2018:3365
  Packages:
        atomic-1.22.1-25.git5a342e3.el7.x86_64
        atomic-registries-1.22.1-25.git5a342e3.el7.x86_64
        buildah-1.2-2.gitbe87762.el7.x86_64
        container-storage-setup-0.11.0-2.git5eaf76c.el7.noarch
        containernetworking-plugins-0.7.1-1.el7.x86_64
        docker-1.13.1-75.git8633870.el7_5.x86_64
        docker-client-1.13.1-75.git8633870.el7_5.x86_64
        docker-common-1.13.1-75.git8633870.el7_5.x86_64
        docker-distribution-2.6.2-2.git48294d9.el7.x86_64
        docker-logrotate-1.13.1-75.git8633870.el7_5.x86_64
        docker-lvm-plugin-1.13.1-75.git8633870.el7_5.x86_64
        docker-novolume-plugin-1.13.1-75.git8633870.el7_5.x86_64
        docker-rhel-push-plugin-1.13.1-75.git8633870.el7_5.x86_64
        docker-v1.10-migrator-1.13.1-75.git8633870.el7_5.x86_64
        driverctl-0.95-1.el7.noarch
        etcd-3.2.22-1.el7.x86_64
        flannel-0.7.1-4.el7.x86_64
        gomtree-0.5.0-0.2.git16da0f8.el7.x86_64
        libev-4.15-7.el7.x86_64
        libev-devel-4.15-7.el7.x86_64
        libssh-0.7.1-3.el7.x86_64
        libssh-devel-0.7.1-3.el7.x86_64
        oci-register-machine-0-6.git2b44233.el7.x86_64
        oci-systemd-hook-0.1.17-2.git83283a0.el7.x86_64
        oci-umount-2.3.3-3.gite3c9055.el7.x86_64
        ostree-2018.5-1.el7.x86_64
        ostree-devel-2018.5-1.el7.x86_64
        ostree-fuse-2018.5-1.el7.x86_64
        ostree-grub2-2018.5-1.el7.x86_64
        python-backports-lzma-0.0.2-9.el7.x86_64
        python-docker-py-1.10.6-4.el7.noarch
        python-docker-pycreds-1.10.6-4.el7.noarch
        python-flask-0.10.1-4.el7.noarch
        python-gevent-1.0-3.el7.x86_64
        python-greenlet-0.4.2-4.el7.x86_64
        python-itsdangerous-0.23-2.el7.noarch
        python-pytoml-0.1.14-1.git7dea353.el7.noarch
        python-websocket-client-0.32.0-116.el7.noarch
        python-werkzeug-0.9.1-2.el7.noarch
        rhel-system-roles-1.0-4.el7.noarch
        runc-1.0.0-52.dev.git70ca035.el7_5.x86_64
        skopeo-0.1.31-1.dev.gitae64ff7.el7.x86_64
        skopeo-containers-0.1.31-1.dev.gitae64ff7.el7.x86_64

Comment 22 jcallaha 2019-02-12 20:53:23 UTC
Created attachment 1534240 [details]
verification screenshot

Comment 23 Brad Buckingham 2019-05-10 02:16:21 UTC
*** Bug 1640420 has been marked as a duplicate of this bug. ***

Comment 26 errata-xmlrpc 2019-05-14 12:36:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.