Bug 1640420 - Content View incremental update copy too many rpms and may break yum update. [NEEDINFO]
Summary: Content View incremental update copy too many rpms and may break yum update.
Keywords:
Status: CLOSED DUPLICATE of bug 1508169
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-18 02:57 UTC by Hao Chang Yu
Modified: 2019-05-10 02:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-10 02:16:21 UTC
Target Upstream Version:
bbuckingham: needinfo? (hyu)


Attachments (Terms of Use)

Description Hao Chang Yu 2018-10-18 02:57:26 UTC
Description of problem:
Perform a CV incremental update by adding 1 erratum (RHBA-2018:1916) to a CV. This erratum only have 7 following rpms but Satellite ended up copying 110 rpms. glibc is 1 of those rpms. Satellite copied the latest version of glibc but didn't copy its dependencies such as "glibc-devel" and "glibc-headers". These 3 rpms must be installed with the exact same version (if older version of glib-{devel|headers} is installed). Therefore, the yum update failed on client side.

"subscription-manager-1.20.10-7.el6.x86_64.rpm",
"subscription-manager-firstboot-1.20.10-7.el6.x86_64.rpm",
"subscription-manager-gui-1.20.10-7.el6.x86_64.rpm",
"subscription-manager-migration-1.20.10-7.el6.x86_64.rpm",
"subscription-manager-migration-data-2.0.43-1.el6.noarch.rpm",
"subscription-manager-rhsm-1.20.10-7.el6.x86_64.rpm",
"subscription-manager-rhsm-certificates-1.20.10-7.el6.x86_64.rpm"

How reproducible:
1) Create a CV and add rhel-6-server-rpms repo to the CV.
2) Filter the CV to exclude all errata after 11/05/2016 (RHEL 6.8 release date)
3) Publish the CV.
4) After that do the incremental update

hammer content-view version incremental-update --errata-ids RHBA-2018:1916 --content-view-version-id <cv version id>

Actual results:
Satellite simply copy all the available latest version of the dependencies without checking the minimum requires version by the parent rpms. When running "yum update subscription-manager", yum doesn't even install those 100 dependencies.

Expected results:
Satellite should only copy the needed dependencies.

Comment 2 Brad Buckingham 2018-11-08 21:12:18 UTC
Hi Hao,

This appears to be a duplicate of bug 1508169.  Can you take a look and confirm?


Note You need to log in before you can comment on or make changes to this bug.