Bug 150843 - yum-2.2.0 accesses the web in >>clean<< mode even if >>-C<< is used
yum-2.2.0 accesses the web in >>clean<< mode even if >>-C<< is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 166367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 04:19 EST by Niki W. Waibel
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niki W. Waibel 2005-03-11 04:19:51 EST
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; SunOS sun4u; U)  [en]

Description of problem:
yum-2.2.0 accesses the web or proxy server in >>clean<< mode (also even if >>-
C<< is used) and reports:
        Cannot find a valid baseurl for repo: base
if
    a) you use --enable-repo=base
    b) there is no proxy / no web available

this did not happen in yum-2.1.12-0.fc3 (prev version).

Version-Release number of selected component (if applicable):
yum-2.2.0-0.fc3

How reproducible:
Always

Steps to Reproduce:
1. # ftp_proxy="http://nosuchserver:8080" \
http_proxy="http://nosuchserver:8080" \
https_proxy="http://nosuchserver:8080" \
yum -y -C clean packages
Cleaning up Packages
0 packages removed

2. # ftp_proxy="http://nosuchserver:8080" \
http_proxy="http://nosuchserver:8080" \
https_proxy="http://nosuchserver:8080" \
yum -y -C --enablerepo=base clean packages
Cannot find a valid baseurl for repo: base


Actual Results:  after 1: all ok -- no web access.
after 2: yum tries to access the web. in this demo-case via an invalid proxy. it 
reports that it cannot find the baseurl.

Expected Results:  it is correct that yum is not able to find the baseurl. but it should at least 
continue cleaning the packages and tread that as a warning instead an error. the 
packages should be cleaned.

Additional info:

yum did not report and error and cleaned the packages in yum-2.1.12-0.fc3 (prev 
version).
Comment 1 Seth Vidal 2005-07-29 14:51:00 EDT
this should be fixed in recent versions of yum - closing as errata
Comment 2 Niki W. Waibel 2005-08-01 08:27:58 EDT
sorry, but i've the same trouble with yum-2.2.1-0.fc3.
Comment 3 Niki W. Waibel 2005-08-05 06:36:33 EDT
same trouble using yum-2.2.2-0.fc3
Comment 4 Rahul Sundaram 2005-08-27 16:02:36 EDT
*** Bug 166367 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2005-09-21 15:25:19 EDT
I think by recent Seth actually meant the 2.4 series

Note You need to log in before you can comment on or make changes to this bug.