Bug 166367 - yum tries to contact repository even if -C (cache) is specified
yum tries to contact repository even if -C (cache) is specified
Status: CLOSED DUPLICATE of bug 150843
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-19 15:57 EDT by Hugo Cisneiros
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-27 16:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugo Cisneiros 2005-08-19 15:57:43 EDT
Description of problem:

When not online, and specifying -C in the command line, yum still tries to
contact a repository. When online, -C works well and reads from cache, but still
contacts a repository.

This is applicable when someone is offline and tries to search for some package
in the yum cache, doing for example:

yum -C search gxine


Version-Release number of selected component (if applicable):

I tried with these versions of yum:
   * yum-2.3.2-7
   * yum-2.3.4-0 (updates/fc4/testing)
   * yum-2.4.0-0 (updates/fc4/testing)

How reproducible:

Steps to Reproduce:
1. go offline or block your internet connection to the outside
2. yum -C search <package>
  
Actual results:

yum tries to contact a repository and waits for a very long time (or forever, I
didn't wait it for finish). Network activity shows that yum is trying to contact
some server on port 80.

Expected results:

yum should read only from the cache.
Comment 1 Rahul Sundaram 2005-08-27 16:02:29 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 150843 ***

Note You need to log in before you can comment on or make changes to this bug.