Bug 1508451 - [ceph-iscsi-cli]: pools and images with hyphens ('-') are rejected by the API
Summary: [ceph-iscsi-cli]: pools and images with hyphens ('-') are rejected by the API
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 3.1
Assignee: Jason Dillaman
QA Contact: Manohar Murthy
Bara Ancincova
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1494421 1584264
TreeView+ depends on / blocked
 
Reported: 2017-11-01 13:05 UTC by Jason Dillaman
Modified: 2018-09-26 18:18 UTC (History)
5 users (show)

(edit)
.Pools and images with hyphens ('-') are no longer rejected by the API

Previously, the iSCSI `gwcli` utility did not support hyphens in pool or image names. As such it was not possible to create a disk using a pool or image name that included hyphens ("-") by using the iSCSI `gwcli` utility.

With this update to {product}, the iSCSI `gwcli` utility correctly handles hyphens. As such creating a disk using a pool or image name with hyphens is now supported.
Clone Of:
(edit)
Last Closed: 2018-09-26 18:16:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2819 None None None 2018-09-26 18:18 UTC
Github ceph-iscsi-cli/pull/41 None None None 2017-11-01 13:06 UTC

Description Jason Dillaman 2017-11-01 13:05:18 UTC
Description of problem:
Pools or images with hyphens in their name are rejected by the API and cannot be used. This restriction should not exist and should be relaxed.

Version-Release number of selected component (if applicable):
2.5

How reproducible:
100%

Steps to Reproduce:
1. use gwcli
2. attempt to create a disk using a pool or image name that includes a hyphen

Actual results:
The disk creation is rejected by the API

Expected results:
The disk creation should succeed.

Comment 12 errata-xmlrpc 2018-09-26 18:16:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.