Bug 1508506 - [Ceph-ansible]: Stopping of NFS-server service required prior to installation of RGW-NFS
Summary: [Ceph-ansible]: Stopping of NFS-server service required prior to installation...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z1
: 3.3
Assignee: Ali Maredia
QA Contact: Ameena Suhani S H
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-11-01 15:02 UTC by vidushi
Modified: 2019-10-22 13:29 UTC (History)
17 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.30-1.el7cp Ubuntu: ceph-ansible_3.2.30-2redhat1
Doc Type: Bug Fix
Doc Text:
.The `nfs-server` service is stopped and disabled automatically on the NFS Ganesha node When the `nfs-server` service was running on the NFS Ganesha node, an attempt to start the NFS Ganesha instance after its installation failed. With this update, the `nfs-server` service is automatically stopped and disabled on the NFS Ganesha node before installing NFS Ganesha. As a result, the NFS Ganesha instance starts as expected after its installation.
Clone Of:
Environment:
Last Closed: 2019-10-22 13:29:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3173 None None None 2019-10-22 13:29:20 UTC
Github ceph ceph-ansible pull 2488 None None None 2018-04-12 18:32:04 UTC
Github ceph ceph-ansible pull 2514 None None None 2018-04-12 18:32:56 UTC
Github ceph ceph-ansible pull 4551 None None None 2019-10-07 08:40:38 UTC

Description vidushi 2017-11-01 15:02:08 UTC
Description of problem:
Stopping/disabling kNFS service required before installing NFS-Ganesha via ceph-ansible. 

Version-Release number of selected component (if applicable):
ceph-ansible-3.0.4-1.el7cp.noarch

How reproducible:
always

Steps to Reproduce:
1. Configured ceph-ansible to have a NFS role.
2. Ran ansible-playbook (site.yml)
3. After installation, Check for the nfs-ganesha service. It fails to start.

Actual results:


Expected results:


Additional info:
For details refer BZ https://bugzilla.redhat.com/show_bug.cgi?id=1452762

Comment 4 Ali Maredia 2017-11-03 17:49:12 UTC
Bara,

The exact name of the service is "nfs-server". In your description on this bug, everywhere you say "nfs-service" should be "nfs-server". 

-Ali

Comment 7 leseb 2018-03-15 13:55:29 UTC
Why was nfs-server running in the first place?
Looks like a system misconfiguration to me.

Comment 8 Alfredo Deza 2018-03-16 11:23:53 UTC
I get that this might be a system misconfiguration, but why wouldn't ceph-ansible be able to stop the service if it is running in order to continue the installation?

Comment 10 leseb 2018-03-21 07:46:29 UTC
Ok, so this sounds more like a request.
I didn't get that this was on purpose.
I guess we can if the service runs and stop it/disable it.

However, I'm just really hesitant changing the system configuration, if kNFS is running it might be for a good reason.

The best thing we should do IMHO is to check if the service runs, fail the playbook and ask to stop it before pursuing the installation.

Is that acceptable to everyone?
Thanks

Comment 11 vidushi 2018-03-21 12:53:40 UTC
(In reply to leseb from comment #10)
> Ok, so this sounds more like a request.
> I didn't get that this was on purpose.
> I guess we can if the service runs and stop it/disable it.
> 
> However, I'm just really hesitant changing the system configuration, if kNFS
> is running it might be for a good reason.
> 
> The best thing we should do IMHO is to check if the service runs, fail the
> playbook and ask to stop it before pursuing the installation.
> 
> Is that acceptable to everyone?
> Thanks

Hi leseb,

When we do the manual way of installing nfs-ganesha, it is mandatory to stop and disable kNFS before installing nfs-ganesha-rgw. NFS-Ganesha will not start if another NFS instance is running.  

As per the doc:
" If the nfs-service service is running, stop and disable it:
# systemctl stop nfs-server.service
# systemctl disable nfs-server.service "

As we are automating nfs-ganesha-rgw installation in 3.0, it will be better to stop and disable nfs-server.service via ceph-ansible. 

Thanks,
Vidushi

Comment 12 Ali Maredia 2018-04-02 17:56:23 UTC
Here is a PR that stops the service before the nfs-ganesha service can be started:

https://github.com/ceph/ceph-ansible/pull/2488

Comment 13 Ali Maredia 2018-04-12 18:27:32 UTC
The above PR has been merged. Ceph-ansible now stops nfs-server via systemd if before it start nfs-ganesha.

Comment 28 Ameena Suhani S H 2019-10-15 11:06:04 UTC
Verified using ceph-ansible-3.2.29-1.el7cp.noarch.

Moving to VERIFIED state.

Comment 30 errata-xmlrpc 2019-10-22 13:29:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3173


Note You need to log in before you can comment on or make changes to this bug.