Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1508733 - yum module bug in ansible 2.4.0.0
yum module bug in ansible 2.4.0.0
Status: CLOSED ERRATA
Product: Red Hat Ansible Engine
Classification: Red Hat
Component: ansible (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Pavel Cahyna
qe-baseos-daemons
: Extras
Depends On: 1509360
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-02 02:15 EDT by Chen Li Zhong
Modified: 2018-04-18 10:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: ansible-2.4.1.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-14 05:02:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ansible/ansible/issues/31412 None None None 2017-11-02 12:15 EDT
Github ansible/ansible/issues/31859 None None None 2017-11-10 13:04 EST
Red Hat Product Errata RHBA-2017:3196 normal SHIPPED_LIVE ansible bug fix update 2017-11-14 10:00:58 EST

  None (edit)
Description Chen Li Zhong 2017-11-02 02:15:08 EDT
Description of problem:

In RHEL 7 extra rpms repo, Ansible 2.4.0.0 is provided. But there is bug of yum module. Yum module is frequently used module for Redhat, please update ansible rpm in redhat channel or release the 2.4.1.

yum module doesn't detect package updates anymore 
https://github.com/ansible/ansible/issues/31412 



Version-Release number of selected component (if applicable):
Ansible 2.4.0.0

How reproducible:

Below command always return "all packages are up to date".

ansible localhost -m yum -a "name=irqbalance state=latest"

Steps to Reproduce:


[root@mariadb_host ~]# uname -a
Linux mariadb_host 3.10.0-327.el7.x86_64 #1 SMP Thu Oct 29 17:29:29 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux


[root@mariadb_host ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)


[root@mariadb_host ~]# ansible --version
ansible 2.4.0.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Oct 11 2015, 17:47:16) [GCC 4.8.3 20140911 (Red Hat 4.8.3-9)]


[root@mariadb_host ~]# rpm -qa|grep irqbalance
irqbalance-1.0.7-5.el7.x86_64


[root@mariadb_host ~]# ansible localhost -m yum -a "name=irqbalance state=latest"
localhost | SUCCESS => {
    "changed": false, 
    "failed": false, 
    "msg": "", 
    "rc": 0, 
    "results": [
        "All packages providing irqbalance are up to date", 
        ""
    ]
}


[root@mariadb_host ~]# yum install irqbalance
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package irqbalance.x86_64 3:1.0.7-5.el7 will be updated
---> Package irqbalance.x86_64 3:1.0.7-10.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                          Arch                                         Version                                              Repository                                                Size
===================================================================================================================================================================================================================
Updating:
 irqbalance                                       x86_64                                       3:1.0.7-10.el7                                       rhel-7-server-rpms                                        45 k

Transaction Summary
===================================================================================================================================================================================================================
Upgrade  1 Package

Total download size: 45 k
Is this ok [y/d/N]: 



Actual results:


Expected results:

Please release the ansible 2.4.1.0 ASAP

Additional info:
Comment 4 Pavel Cahyna 2017-11-10 12:52:54 EST
Note for testing: I was able to reproduce the bug only with packages with a nonzero epoch.

# ansible -C -c local -i localhost, -m yum -a 'name=NetworkManager state=latest' localhost
localhost | SUCCESS => {
    "changed": false, 
    "changes": {
        "installed": [], 
        "updated": []
    }, 
    "failed": false, 
    "msg": "", 
    "rc": 0, 
    "results": [
        "All packages providing NetworkManager are up to date"
    ]
}

(NetworkManager is at version 1:1.8.0-9.el7)

but

# ansible -C -c local -i localhost, -m yum -a 'name=tzdata state=latest' localhost
localhost | SUCCESS => {
    "changed": true, 
    "changes": {
        "installed": [], 
        "updated": [
            [
                "tzdata", 
                "2017c-1.el7.noarch from rhel-7-server-rpms"
            ]
        ]
    }, 
    "failed": false, 
    "msg": "", 
    "rc": 0, 
    "results": []
}

(tzdata is at version 0:2017b-1.el7)
Comment 7 errata-xmlrpc 2017-11-14 05:02:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3196

Note You need to log in before you can comment on or make changes to this bug.