Bug 150921 - hcid not startet on boot
Summary: hcid not startet on boot
Status: CLOSED DUPLICATE of bug 176522
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-12 00:26 UTC by Christoph Wickert
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 11:45:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/boot.log (78.13 KB, text/plain)
2005-03-12 00:30 UTC, Christoph Wickert
no flags Details
Core 3 modprobe.conf (982 bytes, text/plain)
2005-08-09 17:31 UTC, Christoph Wickert
no flags Details

Description Christoph Wickert 2005-03-12 00:26:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
hcid is not startet on boot, although bluetooth is enabled.

$ LANG=C chkconfig --list bluetooth
bluetooth       0:off   1:off   2:on    3:on    4:on    5:on    6:off

Version-Release number of selected component (if applicable):
bluez-utils-2.10-2

How reproducible:
Always

Steps to Reproduce:
After a fresh boot:
1. $ less /var/log/messages | grep bluetooth
Mar 11 21:55:18 computer bluetooth: Starten von hcid succeeded
Mar 11 21:55:18 computer bluetooth: Starten von sdpd succeeded
_but_
2. $ ps -A | grep hcid
$ /etc/init.d/bluetooth status
hcid wurde gestoppt
sdpd (PID 5072) wird ausgef�hrt...
hidd wurde gestoppt
3. $ /etc/init.d/bluetooth restart
Stopping Bluetooth services:        [FAILED]
Bluetooth-Dienste starten:         [  OK  ]
$ tail -20 /var/log/messages | grep bluetooth
Mar 12 00:57:40 computer bluetooth: Herunterfahren von hciattach failed
Mar 12 00:57:40 computer bluetooth: Herunterfahren von sdpd succeeded
Mar 12 00:57:40 computer bluetooth: Herunterfahren von hcid failed
Mar 12 00:57:40 computer bluetooth: Starten von hcid succeeded
Mar 12 00:57:40 computer bluetooth: Starten von sdpd succeeded

$ /etc/init.d/bluetooth status
hcid (PID 7271) wird ausgef�hrt...
sdpd (PID 7275) wird ausgef�hrt...
hidd wurde gestoppt

Actual Results:  No bluetooth available. I'm not sure what exactly happens, if hcid died or if it did not start at all.

Expected Results:  hcid should start automatically.

Additional info:

I'm using the default hcid.conf file. As a workarount I added '/etc/init.d/bluetooth restart' to /etc/rc.local

Comment 1 Christoph Wickert 2005-03-12 00:30:36 UTC
Created attachment 111915 [details]
/var/log/boot.log

Comment 2 David Woodhouse 2005-08-09 16:48:30 UTC
Does this still happen? Do you have any entries relating to bluetooth or 'bluez'
in /etc/modprobe.conf ?

Comment 3 Christoph Wickert 2005-08-09 17:29:50 UTC
Meanwhile I updated to core 4, so I can't tell if it still happens. I did not
have any bluez related entries in modprobe.conf. Attaching my fc3 modprobe.conf.

Comment 4 Christoph Wickert 2005-08-09 17:31:17 UTC
Created attachment 117584 [details]
Core 3 modprobe.conf

Comment 5 Christoph Wickert 2006-02-09 11:45:57 UTC

*** This bug has been marked as a duplicate of 176522 ***


Note You need to log in before you can comment on or make changes to this bug.