Bug 176522 - Bluetooth daemons need to be started after D-Bus system bus
Bluetooth daemons need to be started after D-Bus system bus
Status: CLOSED DUPLICATE of bug 104058
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 150921 176774 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-23 23:59 EST by Jeffrey C. Ollie
Modified: 2013-03-13 00:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 10:29:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2005-12-23 23:59:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
hcid needs to connect to the D-Bus system bus.  Unfortunately, it hcid is started at priority 25 level and the D-Bus system bus isn't started until priority level 98.  Since the D-Bus system bus isn't available when hcid is started it exits immediately.

Version-Release number of selected component (if applicable):
2.22-2.1

How reproducible:
Always

Steps to Reproduce:
1. chkconfig bluetooth on
2. reboot
3. login and seen that hcid isn't running
  

Actual Results:  Dec 23 10:04:09 lt16585 hcid[2028]: Bluetooth HCI daemon
Dec 23 10:04:09 lt16585 sdpd[2031]: Bluetooth SDP daemon
Dec 23 10:04:10 lt16585 hcid[2028]: Can't open system message bus connection: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Dec 23 10:04:10 lt16585 hcid[2028]: Unable to get on D-BUS


Expected Results:  Dec 23 10:08:57 lt16585 hcid[2819]: Bluetooth HCI daemon
Dec 23 10:08:57 lt16585 sdpd[2822]: Bluetooth SDP daemon
Dec 23 10:08:57 lt16585 hcid[2819]: Registering DBUS Path: /org/bluez/Device/hci0
Dec 23 10:08:57 lt16585 hcid[2819]: HCI dev 0 up
Dec 23 10:08:57 lt16585 hcid[2819]: Starting security manager 0
Dec 23 10:08:57 lt16585 hcid[2819]: Registering DBUS Path: /org/bluez/Manager/default/Controller
Dec 23 10:08:57 lt16585 hcid[2819]: Registering DBUS Path: /org/bluez/Manager/hci0/Controller


Additional info:
Comment 1 David Woodhouse 2005-12-24 03:44:42 EST
I think we need to start dbus earlier.
Comment 2 Reuben Farrelly 2006-01-14 05:17:31 EST
*** Bug 176774 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Aillon 2006-01-27 14:26:28 EST
There probably should be an API in dbus to let you monitor when the bus becomes
active and goes away.  This is probably not a blocker, though.  Moving to target.
Comment 4 David Woodhouse 2006-01-27 14:40:20 EST
If bluetooth can't start up because dbus is starting too late, then that's a
blocker. I thought I saw a report that we'd started dbus earlier though --
although I don't see it in this bug or in bug #176774 at first glance. 

Let's not let this bug evolve into the RFE you mention in comment #3 -- keep it
simply for "dbus ate my bluetooth dæmon", and please close it if that's no
longer true. Switching back to blocker.
Comment 5 John (J5) Palmieri 2006-01-27 14:49:24 EST
There is an API.  Setup a timeout when the bus goes away and check if you can
connect at each interval.  BTW D-Bus now starts before bluetooth except there is
no way to relink already created init scripts with checkconfig so you will only
get it in a fresh install.  I also filed a bug on expat (Bug #178743).  It needs
to be moved to /lib since dbus requires it.
Comment 6 Matthias Clasen 2006-02-05 00:04:47 EST
Is this a dupe of bug 104058 ?
Comment 7 John (J5) Palmieri 2006-02-06 10:29:46 EST

*** This bug has been marked as a duplicate of 104058 ***
Comment 8 Christoph Wickert 2006-02-09 06:46:04 EST
*** Bug 150921 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.