Bug 150935 - gnupg fails to create a key pair when run for the first time
gnupg fails to create a key pair when run for the first time
Status: CLOSED DUPLICATE of bug 142206
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnupg (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-03-12 00:47 EST by Ian Laurie
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-07 14:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2005-03-12 00:47:18 EST
Description of problem:
gnupg fails to create a key pair.  It looks like the directory
~/.gnupg doesn't get created as it should when run for the first time.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Launch gpg to generate a key pair for the first time.
Actual results:
Trying to generate a key pair using the --gen-key option, you get an
error as follows:

helix# gpg --gen-key
gpg: no writable public keyring found: eof
Key generation failed: eof
gpg: can't create `/root/.gnupg/random_seed': No such file or directory

Expected results:
Should create the ~/.gnupg directory and create the key pairs on first

Additional info:
FC3 seems to have the same problem.  Worked OK in RHEL3 from what I
Comment 1 Peter Bieringer 2005-03-30 07:09:15 EST
Can confirm, see also:

Comment 2 Nalin Dahyabhai 2005-09-07 14:20:01 EDT

*** This bug has been marked as a duplicate of 142206 ***

Note You need to log in before you can comment on or make changes to this bug.