Bug 150944 - fetchmail shouldn't depend on smtpdaemon anymore
fetchmail shouldn't depend on smtpdaemon anymore
Status: CLOSED DUPLICATE of bug 66396
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-12 05:14 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-02 17:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2005-03-12 05:14:05 EST
+++ This bug was initially created as a clone of Bug #66396 +++

Description of Problem:

fetchmail on RH 7.2 & 7.3 still depends on smtpdaemon virtual package, though
it can default to /usr/bin/procmail in case no SMTP listener is found.

Version-Release number of selected component (if applicable):

fetchmail-5.9.0-1 (and later too, possibly)

How Reproducible:

Always

Steps to Reproduce:

binand@binand[~]:(14) rpm -qR fetchmail
smtpdaemon
[snip]

binand@binand[~]:(22) fetchmail mail.xxxxxxxx.com --proto imap --fetchlimit 1 
--keep
fetchmail: can't raise the listener; falling back to /usr/bin/procmail -d %T

I suppose the dependency of smtpdaemon can be removed from fetchmail now.

Also, a patch to use the -f option to procmail would be welcome.
Comment 1 Robert Scheck 2005-03-13 07:19:26 EST
This patch is a duplicate of bug #66396 and maybe should be solved for Fedora
Core development, that the initial bug can also be closed.
Comment 2 Patrice Dumas 2005-03-16 18:07:48 EST
Yep, I think the original bug report shouldn't be forgotten, as it is still in
fedora core, that's why I cloned it.
Comment 3 Miloslav Trmač 2005-06-02 17:39:06 EDT
Thanks for the reminder.

In these cases, it is usually better to just add a comment stating that
the same bug is the current version to the original report.

*** This bug has been marked as a duplicate of 66396 ***

Note You need to log in before you can comment on or make changes to this bug.