Bug 66396 - fetchmail shouldn't depend on smtpdaemon anymore
fetchmail shouldn't depend on smtpdaemon anymore
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Reopened
: 150944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-09 19:07 EDT by Binand Sethumadhavan
Modified: 2008-09-18 05:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 10:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Binand Sethumadhavan 2002-06-09 19:07:22 EDT
Description of Problem:

fetchmail on RH 7.2 & 7.3 still depends on smtpdaemon virtual package, though
it can default to /usr/bin/procmail in case no SMTP listener is found.

Version-Release number of selected component (if applicable):

fetchmail-5.9.0-1 (and later too, possibly)

How Reproducible:

Always

Steps to Reproduce:

binand@binand[~]:(14) rpm -qR fetchmail
smtpdaemon
[snip]

binand@binand[~]:(22) fetchmail mail.xxxxxxxx.com --proto imap --fetchlimit 1 
--keep
fetchmail: can't raise the listener; falling back to /usr/bin/procmail -d %T

I suppose the dependency of smtpdaemon can be removed from fetchmail now.

Also, a patch to use the -f option to procmail would be welcome.
Comment 1 Miloslav Trmač 2005-06-02 17:39:08 EDT
*** Bug 150944 has been marked as a duplicate of this bug. ***
Comment 2 Miloslav Trmač 2005-06-03 11:20:11 EDT
I'm sorry about the late response.

The fallback MDA option is off (by default and in our packages) since
fetchmail-5.9.13 because using it can lead to hard-to-reproduce behavior
changes when the local MTA is not available, e.g. during high system load.

Even the most minimal system installation should have a local sendmail
to allow error reporting from cron jobs (logrotate at minimum) anyway.
Comment 3 Patrice Dumas 2005-06-05 12:54:57 EDT
A mta that accepts mails on its stdin is required on minimal installs, not one
that listen on a port. ssmtp was such program but not in redhat since a long
time (I use esmtp), but these are not in fedora core. They can provide
smtpdaemon, though. 

Therefore I believe that that requirement is a bit misleading because either
send only mta should not provide smtpdaemon, and fetchmail cannot be installed,
or those send-only mta provide smtpdaemon and the users may be misleaded in
thinking that there is a fallback to a mta and this is not the case.

Moreover if there is a package that provide smtpdaemon in the most minimal
system, maybe it shouldn't be required by fetchmail ?

Not a big deal anyway, especially since if I'm not wrong there is no send only
mta in fedora core (though there could be one in extras).
Comment 4 Miloslav Trmač 2005-06-07 12:03:22 EDT
Actually, fetchmail is sending bounce mail _always_ to localhost SMTP, so
a running SMTP daemon is really required if you don't want to lose
mail without a trace.

(Yes, it is strange.  Please talk to upstream maintainers, which currently
seems to be http://lists.berlios.de/mailman/listinfo/fetchmail-devel,
if you want that changed.)
Comment 5 Patrice Dumas 2007-11-10 06:42:44 EST
What about using --enable-fallback=procmail to avoid the 
smtpdaemon (soon to be server(smtp)) dependency, and instead
have a dependency on procmail? It is much lighter than 
any of the smtp servers.

Comment 6 Patrice Dumas 2007-11-10 09:23:31 EST
Also I may be wrong, but I have read the code a little
and it seems to me that smtp_bouncemail isn't used when 
no mda is used, no smtp server is found on localhost and 
enable-fallback is set.
Comment 7 Patrice Dumas 2008-03-18 17:36:52 EDT
It would be nice to solve that issue, and if not, replace
smtpdaemon requires by server(smtp) requires.
Comment 8 Patrice Dumas 2008-07-10 11:36:51 EDT
In Comment #6 (and #5) it seems to me that I give enough information
to change the smtp server Requires by a procmail requires. Wouldn't
it be better?
Comment 9 Patrice Dumas 2008-09-17 11:56:56 EDT
This seems to be fixed in CVS, but it look like the build was 
interrupted. Could you please restart it, otherwise I could also 
I can take care of rebuilding it if you prefer.
Comment 10 Vitezslav Crhonek 2008-09-18 05:00:52 EDT
Thanks for giving a notice - build crashed on patch fuzziness, I'll fix it.

Note You need to log in before you can comment on or make changes to this bug.