Bug 150953 - input field editing does not display properly
input field editing does not display properly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 151600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-12 13:14 EST by Warren Sturm
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-13 05:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test document for the input field problem (5.57 KB, application/vnd.sun.xml.writer)
2005-06-17 20:52 EDT, Warren Sturm
no flags Details
/etc/fonts/fonts.conf (15.53 KB, text/plain)
2005-07-05 22:52 EDT, Warren Sturm
no flags Details
/etc/fonts/fonts.conf (15.53 KB, text/plain)
2005-07-05 22:54 EDT, Warren Sturm
no flags Details
/etc/fonts/fonts.conf (15.53 KB, text/plain)
2005-07-07 01:32 EDT, Warren Sturm
no flags Details
/etc/fonts/local.conf (350 bytes, text/plain)
2005-07-07 01:33 EDT, Warren Sturm
no flags Details

  None (edit)
Description Warren Sturm 2005-03-12 13:14:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
When editing an input field in the word processor the text within is
displayed highlighted.  If you select in the text the highlighting is
off and the text disappears until either a character is added or deleted.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-9.5.0.fc3

How reproducible:
Always

Steps to Reproduce:
1.open a blank document
2.menu Insert->Fields->Other-Functions tab-Input Field - Insert button
3. add some text to the large text area and select OK.
4. click in the new field then click in the edit area.
    

Actual Results:  The highlighting turns off and the text disappears
with it

Expected Results:  Highlighting turns off and text appears normal

Additional info:

adding a character will cause the text to display.
Comment 1 Caolan McNamara 2005-03-16 09:23:50 EST
strange, I don't see this with openoffice.org-1.1.3-9.5.0.fc3. What's your gnome
application font ?

caolanm->dcbw: do you see this behaviour ?
Comment 2 Warren Sturm 2005-03-16 18:30:47 EST
Font Preferences: Application Font: Sans Regular 10
Comment 3 Caolan McNamara 2005-03-21 03:55:46 EST
*** Bug 151600 has been marked as a duplicate of this bug. ***
Comment 4 P Jones 2005-03-21 05:45:01 EST
Just confirming that this IS the same problem as reported in 151600. FWIW, I
have my default serif and sans-serif fonts set in fonts.local to be Bitstream
Vera and Bitstream Vera Sans.
Comment 5 Caolan McNamara 2005-06-17 09:04:04 EDT
Just to check, does this 
a) still exist
b) happen in a specific locale ?
c) happen only with numbers, or with numbers and text ?
Comment 6 Warren Sturm 2005-06-17 20:51:08 EDT
a) Yes
b) I have not set a locale.  LANG=en_CA.UTF-8
c) either

I will attach the file that experiences the problem.
Comment 7 Warren Sturm 2005-06-17 20:52:43 EDT
Created attachment 115647 [details]
test document for the input field problem
Comment 8 Caolan McNamara 2005-06-20 10:59:53 EDT
Still can't reproduce this. Baffled.
Comment 9 Caolan McNamara 2005-07-05 04:49:46 EDT
Can you attach your 
/etc/fonts/fonts.conf
and
/etc/fonts/local.conf
Comment 10 Warren Sturm 2005-07-05 22:52:34 EDT
Created attachment 116396 [details]
/etc/fonts/fonts.conf
Comment 11 Warren Sturm 2005-07-05 22:54:44 EDT
Created attachment 116397 [details]
/etc/fonts/fonts.conf
Comment 12 Warren Sturm 2005-07-07 01:32:39 EDT
Created attachment 116456 [details]
/etc/fonts/fonts.conf
Comment 13 Warren Sturm 2005-07-07 01:33:35 EDT
Created attachment 116457 [details]
/etc/fonts/local.conf
Comment 14 Warren Sturm 2005-07-07 01:36:50 EDT
Sorry about the multiple fonts.conf.  I tried a couple of times to create the
attachment but got no response from bugzlla that it had been created.
Comment 15 Caolan McNamara 2005-07-11 13:03:36 EDT
Still worked for me with your fonts.conf :-(

Note You need to log in before you can comment on or make changes to this bug.