Bug 150973 - Toggling from GUI to CLI to GUI locks up computer
Toggling from GUI to CLI to GUI locks up computer
Status: CLOSED DUPLICATE of bug 151163
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-13 01:12 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 03:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf for reference (2.93 KB, text/plain)
2005-03-13 01:17 EST, Jim Cornette
no flags Details
This log should describe the activity up until the crash (33.24 KB, text/plain)
2005-03-13 01:20 EST, Jim Cornette
no flags Details
log with latest dri and drivers from Freedesktop (33.94 KB, text/plain)
2005-03-13 11:35 EST, Jim Cornette
no flags Details
Self compiled - still erors out (33.56 KB, text/plain)
2005-03-13 19:05 EST, Jim Cornette
no flags Details
CVS version compilation does same thing (32.77 KB, text/plain)
2005-03-30 23:14 EST, Jim Cornette
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2556 None None None Never

  None (edit)
Description Jim Cornette 2005-03-13 01:12:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
Whenever I try to run programs like tuxracer or xfce, I get an
immediate lockup of the computer.
When I try to change from the GUI to the terminal, then back to the
GUI, I get a lockup where the screen has residue images in it, the
mouse can b moved, but there is no system response other than this.
I have tried to replace the Fedora drivers for
/usr/X11R6/lib/modules/dri/radeon_dri.so
and
/usr/X11R6/lib/modules/drivers/radeon_drv.o and ati_drv.o
with drivers available from fredesktop.org and the problem does not
happen.
Whenever I install a later version of xorg-x11 from fedora, it
overwrites the drivers I added and I test the system to see if it has
been repaired. So far, there has been no improvements from FC3 to
current development.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-10

How reproducible:
Always

Steps to Reproduce:
1. start x via runlevel 3 and using startx as user
2. try to change to terminal, then back to X
3. Reset computer after lockup
    

Actual Results:  1. X starts fine
2. X crashes
3. computer goes into file integrity check

Expected Results:  I expected tuxracer to work, xfce to work and to be
able to switch to terminals then back for processes that I might like
to still have running after closing down X.

Additional info:

There is a bug filed in fredesktop.org already

https://bugs.freedesktop.org/show_bug.cgi?id=2556
Comment 1 Jim Cornette 2005-03-13 01:14:36 EST
sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21
IEEE-1394a-2000 Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation
DP83815 (MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
Comment 2 Jim Cornette 2005-03-13 01:17:22 EST
Created attachment 111933 [details]
xorg.conf  for reference
Comment 3 Jim Cornette 2005-03-13 01:20:50 EST
Created attachment 111934 [details]
This log should describe the activity up until the crash

I assume that Xorg.0.log.old is from the last server startup prior to the
active log.
Comment 4 Jim Cornette 2005-03-13 11:35:14 EST
Created attachment 111947 [details]
log with latest dri and drivers from Freedesktop

As a confirmation that this problem seems to be specific to Fedora and not to
xorg-x11 directly, I replaced the latest drivers for dri and for the ati and
radeon drivers as per previous bug entries. The permissions on the transplanted
drivers are al set to 10444 w/ the owner as root.
The computer works fine w/ tux and switching terminals w/ the hack.
Comment 5 Jim Cornette 2005-03-13 19:05:44 EST
Created attachment 111957 [details]
Self compiled - still erors out

I compiled the source and installed the resulting rpms. The rpms acted the same
as the avaiable binaries. This log is from my compiled versions, same problem.
Comment 6 Jim Cornette 2005-03-30 23:14:08 EST
Created attachment 112501 [details]
CVS version compilation does same thing

In desperation and as a matter of curiousity, I compiled and installed a CVS
version of xorg-x11 to compare it with the rpm binary package released a day or
so ago. The CVS version exhibits the same symptoms. The switching to a VT then
back to X kills the server as well as running tuxracer. The results obtained
from the CVS version render tuxracer far worse than the rpm binaries available
via mirror for Fedora.
Anyway, both are broken.
Comment 7 Mike A. Harris 2005-04-11 05:50:57 EDT
Thanks for reporting this to X.org.  We will track the issue in the
X.org bug report you've provided above.  When a fix becomes available,
we will review it for consideration in future updates for Fedora Core.

Thanks again.

Setting status to "UPSTREAM" for tracking.
Comment 8 Jim Cornette 2005-04-11 11:08:00 EDT
Though bug is closed, the last version from rawhide with binaries dated April
6th failed with the same symptoms. Replacing the binaries with snapshots from
freedesktop.org resolved the busted driver.
https://bugs.freedesktop.org/show_bug.cgi?id=2556
does not seem to have much activity. i'll add the failure results in the bug above.
Comment 9 Jim Cornette 2005-04-14 22:11:02 EDT
xorg-x11-6.8.2-22 seems to eliminate the problem with lockup.
Comment 10 Mike A. Harris 2005-04-15 03:00:59 EDT
That's good news!  Looks like one of the patches nominated for 6.8.3 that
we just added must have fixed it.  I believe the most likely candidate
is:  xorg-x11-6.8.3-radeon-set-fb-location-fdo2698-2079.patch
Comment 11 Mike A. Harris 2005-04-15 03:08:09 EDT

*** This bug has been marked as a duplicate of 151163 ***

Note You need to log in before you can comment on or make changes to this bug.