Bug 151163 - (radeon-vtswitch) radeon driver freezes when switching from X to the console and back
radeon driver freezes when switching from X to the console and back
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 150973 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-15 10:34 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 01:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-03-15 10:34:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050301 Firefox/1.0.1 Galeon/1.3.19

Description of problem:
I have a ATI Radeon Mobility U1 chipset in my laptop. If I switch to the console from X and back to X the display freezes, except for the mouse. There is also a distorted color band across the top. With FC3 and 6.8.1 it worked just fine. With FC3 and 6.8.2 it would hang. With rawhide and 6.8.2 it hangs. With rawhide, 6.8.2, and the radeon_drv.o from 6.8.1 it works just fine.


Option "NoAccel" "true"  works around the issue. Commenting out Load "dri" also works around the issue. Both seem to disable dri. As in no /dev/dri.

Messages in /var/log/Xorg.0.log seem to be the same with the 6.8.1 and 6.8.2 drivers when it works and doesn't work while dri is enabled. An example is below.

(II) RADEON(0): [RESUME] Attempting to re-init Radeon hardware.
(II) RADEON(0): [agp] Mode 0x0f000207 [AGP 0x1002/0xcab0; Card 0x1002/0x4336]

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-10

How reproducible:
Always

Steps to Reproduce:
1. ctrl-alt-f1
2. alt-f7

  

Actual Results:  Frozen display, but mouse still moves

Expected Results:  Working display

Additional info:
Comment 1 Rui Miguel Seabra 2005-03-26 06:19:24 EST
Mouse does move, but an activity indicator like pressing CAPS LOCK and see if
the light turns on is a way to see if the computer is working normally.

When this bug happened to me, CAPS LOCK was frozen.

Also, if you go to console, it's better to go to init 3, then back to init 5, as
that will initialize the card again and it won't freeze.
Comment 2 Rui Miguel Seabra 2005-03-26 06:53:24 EST
Also, a similar freeze appears to happen when launching full-screen gl(-enhanced
too) apps, like ppracer or powermanga or bzflag.

No caps lock light, mouse moves, frozen black screen. In the case of games, I
hear the music playing.

I haven't tested wether you can log into the machine remotely.
Comment 4 Nathan G. Grennan 2005-04-14 01:55:11 EDT
This bug is gone with the latest version of xorg-x11 in development, 6.8.2-22. I
also notice the pattern at the of the screen changed when going from console to X.

I would recommend pushing this version or one like it FC3 updates to replace the
recent 6.8.2-1.
Comment 5 Mike A. Harris 2005-04-15 03:07:07 EDT
xorg-x11-6.8.3-radeon-set-fb-location-fdo2698-2079.patch seems to have
resolved this issue, and numerous other bug reports now.

Adding bug alias "radeon-vtswitch" to allow easier closing of duplicates.
Comment 6 Mike A. Harris 2005-04-15 03:08:24 EDT
*** Bug 150973 has been marked as a duplicate of this bug. ***
Comment 7 Rui Miguel Seabra 2005-04-15 05:00:29 EDT
Confirm. This also works for me now.

Note You need to log in before you can comment on or make changes to this bug.