Bug 151034 - gcc segfaults when compiling qemu sources
gcc segfaults when compiling qemu sources
Status: CLOSED DUPLICATE of bug 138627
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 03:54 EST by Paul Jakma
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 04:03:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source of qemu's target-i386/op.c which caused segv (353.90 KB, application/octet-stream)
2005-03-14 03:56 EST, Paul Jakma
no flags Details
The original C source file which causes the gcc segfault (40.79 KB, text/x-csrc)
2005-03-14 03:57 EST, Paul Jakma
no flags Details

  None (edit)
Description Paul Jakma 2005-03-14 03:54:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3) Gecko/20041020 Galeon/1.3.19

Description of problem:
- retrieve the qemu CVS sources 
  (the attached files are from CVS from 20050314 0830GMT CVS, but the problem
   has been occuring for a while now)
- try compile it on FC3 x86_64 
  (I havn't tried on i386)
- Get segfault in qemu's target-i386/op.c file:

gcc -Wall -O2 -g -fno-strict-aliasing -falign-functions=0 -fno-reorder-blocks -fno-optimize-sibling-calls -I. -I/home/paul/cvs/qemu/target-i386 -I/home/paul/cvs/qemu -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/home/paul/cvs/qemu/fpu -I/home/paul/cvs/qemu/slirp -c -o op.o /home/paul/cvs/qemu/target-i386/op.c
/home/paul/cvs/qemu/target-i386/op.c: In function `op_goto_tb0':
/home/paul/cvs/qemu/target-i386/op.c:1277: warning: cast to pointer from integer of different size
/home/paul/cvs/qemu/target-i386/op.c: In function `op_goto_tb1':
/home/paul/cvs/qemu/target-i386/op.c:1282: warning: cast to pointer from integer of different size
/home/paul/cvs/qemu/target-i386/op.c: In function `op_divw_AX_T0':
/home/paul/cvs/qemu/target-i386/op.c:374: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccTRyOgP.out file, please attach this to your bugreport.

See attached C source file and the preprocessed source which gcc advised me to post to bugzilla.


Version-Release number of selected component (if applicable):
3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1. retrieve qemu CVS
2. configure && make
3. see it segfault in target-i386/op.c
  

Actual Results:  Segfault in gcc

Expected Results:  Should have either compiled the source, or exited with an error.

Additional info:
Comment 1 Paul Jakma 2005-03-14 03:56:12 EST
Created attachment 111967 [details]
preprocessed source of qemu's target-i386/op.c which caused segv
Comment 2 Paul Jakma 2005-03-14 03:57:09 EST
Created attachment 111968 [details]
The original C source file which causes the gcc segfault
Comment 3 Jakub Jelinek 2005-03-14 04:03:15 EST

*** This bug has been marked as a duplicate of 138627 ***

Note You need to log in before you can comment on or make changes to this bug.