Bug 151047 - Yum crashes after update to SQLite-3
Yum crashes after update to SQLite-3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 151048 (view as bug list)
Depends On: 150960
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 08:21 EST by Naadir Jeewa
Modified: 2014-01-21 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 14:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naadir Jeewa 2005-03-14 08:21:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Since the sqlite3 package has been replaced by sqlite-3, Yum fails to process the package list after downloading metadata


Version-Release number of selected component (if applicable):
yum-2.3.1-2 sqlite-3.1.2-1 python-sqlite-1.1.6-1

How reproducible:
Always

Steps to Reproduce:
1. Run yum update
  

Actual Results:  Setting up Update Process
Setting up Repos
newrpms                   100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 107 kB    00:00
newrpms   : ################################################## 385/385
Added 385 new packages, deleted 0 old in 2.07 seconds
primary.xml.gz            100% |=========================| 146 kB    00:00
freshrpms : ################################################## 471/471
Added 471 new packages, deleted 0 old in 1.57 seconds
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 72, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 462, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 960, in updatePkgs
    self.doUpdateSetup()
  File "__init__.py", line 228, in doUpdateSetup
  File "sqlitesack.py", line 225, in returnObsoletes
  File "/usr/src/build/539311-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py", line 104, in __getitem__
KeyError: 'PACKAGES.PKGID'


Expected Results:  Pulling of upgraded headers

Additional info:
Comment 1 Seth Vidal 2005-03-14 08:59:58 EST
*** Bug 151048 has been marked as a duplicate of this bug. ***
Comment 2 Sammy 2005-03-14 11:46:35 EST
Obviously there is buildroot path hardcoded in the library. If you do 
grep it find two binaries main.py and __init__.py that contain the 
string "539311". I could not figure out exactly where this is coming from. 
Looked at yum package and sqlite-python package. It could be coming from 
sqlite itself. 
Comment 3 Sammy 2005-03-14 11:49:15 EST
Just overwriting libsqlite3.so.0.8.6 with the one coming from the sqlite3  
package solves the problem! 
Comment 4 Naadir Jeewa 2005-03-14 12:10:05 EST
I don't think the build root is hardcoded, the debug line is just a
result of the precompilation.
Comment 5 Naadir Jeewa 2005-03-14 12:46:24 EST
I think I'm mistaken, the build root's hardcoded into sqlite somewhere, as I
just rebuilt it. Changing the component to sqlite.
Comment 6 Naadir Jeewa 2005-03-25 23:46:41 EST
Rebuilt rawhide from scratch. Yum works fine despite the SQLite version.
Comment 7 Jeremy Katz 2005-09-21 14:19:17 EDT
I think this has been fixed now

Note You need to log in before you can comment on or make changes to this bug.