Bug 151089 - zsh fails to recompile from source rpm because of an problem related to texi2html
zsh fails to recompile from source rpm because of an problem related to texi2...
Status: CLOSED DUPLICATE of bug 191647
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-03-14 14:36 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-11 18:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-03-14 14:36:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050309 Galeon/1.3.19

Description of problem:
The errors below come from trying to recompile zsh from source rpm after adding Buildrequires: texi2html and installing texi2html. It seems to be a format problem in zsh.texi, or a bug in texi2html.

texi2html 1.76-2

+ texi2html -expand info -split chapter ./zsh.texi
** closing `table' (l. 20575)
*** @end table without corresponding opening (l. 20640)
+ rm -rf /home/builder/rpmbuild/TMP/zsh-4.2.1-root/usr/share/doc/zsh-html-4.2.1
+ /bin/mkdir -p /home/builder/rpmbuild/TMP/zsh-4.2.1-root/usr/share/doc/zsh-html-4.2.1
+ cp -pr 'Doc/*.html' /home/builder/rpmbuild/TMP/zsh-4.2.1-root/usr/share/doc/zsh-html-4.2.1
cp: cannot stat `Doc/*.html': No such file or directory
error: Bad exit status from /home/builder/rpmbuild/TMP/rpm-tmp.29919 (%doc)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpm -i zsh-4.2.0-2.src.rpm
2. cd /usr/src/redhat/SPECS
3. Edit zsh.spec to add BuildRequires: texi2html
4. Make sure texi2html is installed
5. rpmbuild -bb zsh.spec 

Actual Results:  cp: cannot stat `Doc/*.html': No such file or directory

Expected Results:  No errors

Additional info:
Comment 1 Nathan G. Grennan 2005-03-14 14:40:29 EST
I have commented out the html subpackage and have been successful in recompiling
zsh from source rpm.
Comment 2 Mathieu Chouquet-Stringer 2005-12-05 06:31:26 EST
Actually if you replace the following line in the spec file:
%doc Doc/*.html

%doc Doc/zsh/*.html

You should be good to go (even with the texi2html error).

Bug #155239 is actually the same thing.
Comment 3 Christopher Aillon 2006-09-11 18:39:54 EDT
Fixed by 191647.

*** This bug has been marked as a duplicate of 191647 ***

Note You need to log in before you can comment on or make changes to this bug.