Bug 191647 - zsh fails to build with mock
zsh fails to build with mock
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Colin Walters
Mike McLean
: 151089 181838 191811 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
Reported: 2006-05-14 11:18 EDT by Alexander Täschner
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-25 02:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
mock build log (90.72 KB, text/plain)
2006-05-14 11:18 EDT, Alexander Täschner
no flags Details
mock configuration file (1.34 KB, text/plain)
2006-05-14 11:21 EDT, Alexander Täschner
no flags Details
build.log with texi2html (111.83 KB, text/plain)
2006-05-14 11:39 EDT, Alexander Täschner
no flags Details

  None (edit)
Description Alexander Täschner 2006-05-14 11:18:23 EDT
Building the SRPM
using mock fails.

Attached is the build.log.

Because of the wrong repositories in the default mock configuration I used
a modified one which I will attach later.
Comment 1 Alexander Täschner 2006-05-14 11:18:24 EDT
Created attachment 129005 [details]
mock build log
Comment 2 Alexander Täschner 2006-05-14 11:21:57 EDT
Created attachment 129006 [details]
mock configuration file
Comment 3 Alexander Täschner 2006-05-14 11:39:44 EDT
Created attachment 129008 [details]
build.log with texi2html

Adding texi2html to the BuildRequires let mock build the package without new
problems, but rpmdiff show differences.
Comment 4 Alexander Täschner 2006-05-14 12:35:03 EDT
ncurses-devel seems to be needed in order to build

With texi2html and ncurses-devel all files of the rpm are build, but
there are still some MD5 differences shown with rpmdiff.
Comment 5 Brian Pepple 2006-05-17 18:55:11 EDT
*** Bug 191811 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Keating 2006-07-10 15:50:05 EDT
Ping.  A mass rebuild is scheduled for tomorrow, July 11th.  Please try to have
your package fixed by then.
Comment 7 Mike A. Harris 2006-07-25 02:35:13 EDT
Core Rawhide-in-Mock Build Results for x86_64 Mon Jul 24 16:05:03 CDT 2006

Note: This is using a reduced set of packages in the build chroot as
compared to the standard Fedora Extras build system before FC6test1.  See
http://fedoraproject.org/wiki/QA/FixBuildRequires for more
information, including the list of packages removed from the
default build chroot.

Open Bugs which now build, and can be marked CLOSED RAWHIDE:
classpathx-jaf-1.0-7jpp_2fc 192372 ASSIGNED
compat-gcc-296-2.96-136 191696 NEW
epiphany-2.15.1-2 191665 NEW
jakarta-commons-el-1.0-5jpp_2fc 192514 NEW
ldapjdk-4.17-1jpp_4fc 192530 NEW
pygobject2-2.11.0-2 197138 NEW
vorbis-tools-1.1.1-2 197076 NEW
zsh-4.2.5-2 191647 NEW
Comment 8 Christopher Aillon 2006-09-11 18:40:07 EDT
*** Bug 151089 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Aillon 2006-09-11 18:51:12 EDT
*** Bug 181838 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.