Bug 1511169 - neutron API test "test_associate_floating_ip_with_port_from_another_tenant" skips and fails with bug in tempest.conf
Summary: neutron API test "test_associate_floating_ip_with_port_from_another_tenant" s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: unspecified
Hardware: x86_64
OS: All
medium
high
Target Milestone: ---
: 11.0 (Ocata)
Assignee: Ihar Hrachyshka
QA Contact: Martin Kopec
URL:
Whiteboard:
: 1526750 (view as bug list)
Depends On: 1507014 1508835
Blocks: 1526944
TreeView+ depends on / blocked
 
Reported: 2017-11-08 19:58 UTC by Ihar Hrachyshka
Modified: 2018-02-13 16:38 UTC (History)
20 users (show)

Fixed In Version: openstack-tempest-16.0.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1508835
Environment:
Last Closed: 2018-02-13 16:38:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 10476 None None None 2017-11-15 12:59:11 UTC
RDO 10482 None None None 2017-11-15 13:00:03 UTC
Red Hat Product Errata RHBA-2018:0311 normal SHIPPED_LIVE Red Hat OpenStack Platform 11 Bug Fix and Enhancement Advisory 2018-02-14 00:05:57 UTC

Description Ihar Hrachyshka 2017-11-08 19:58:16 UTC
+++ This bug was initially created as a clone of Bug #1508835 +++

+++ This bug was initially created as a clone of Bug #1507014 +++

Description of problem:


neutron tempest test: test_associate_floating_ip_with_port_from_another_tenant fails as this tests is skipped - as it checks if identity_feature_enabled.api_v2_admin is set in tempest.conf.

The Redhat Certification test suite configures the tempest.conf.
By default "api_v2_admin" parameter is not populated in tempest.conf.

As Tripleo (Newton) uses identity APi v2,  even tried with work around in 
https://bugzilla.redhat.com/show_bug.cgi?id=1480269 ,
even after setting identity_feature_enabled.api_v2_admin = True ,
this test still fails with skip exception.

I believe this bug is because of bug in config.py generating tempest.conf.


Version-Release number of selected component (if applicable):
redhat-certification-openstack-5.2
python-tempest-13.0.0-14
openstack-tempest-all-13.0.0-14
python-neutron-tests-9.4.1


How reproducible:


Steps to Reproduce:
1. TripleO setup with OSP10 (Newton)
2. Install Redhat Certification test Suite 5.2 (latest at this time of filing this bug)  
3. Run the Certification test.

Actual results:


Expected results:


Additional info:

below is the stack trace :
Test: neutron.tests.tempest.api.admin.test_floating_ips_admin_actions.FloatingIPAdminTestJSON.test_associate_floating_ip_with_port_from_another_tenant[id-11116ee9-4e99-5b15-b8e1-aa7df92ca589,negative]
Status: FAIL
Error:
_StringException: Empty attachments:
  pythonlogging:''

Traceback (most recent call last):
  File "/tmp/tmp29u2X1_tempest/neutron/neutron/tests/tempest/api/admin/test_floating_ips_admin_actions.py", line 47, in test_associate_floating_ip_with_port_from_another_tenant
    if not CONF.identity_feature_enabled.api_v2_admin:
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 3061, in __getattr__
    return self._conf._get(name, self._group)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2672, in _get
    value = self._do_get(name, group, namespace)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2689, in _do_get
    info = self._get_opt_info(name, group)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 2828, in _get_opt_info
    raise NoSuchOptError(opt_name, group)
oslo_config.cfg.NoSuchOptError: no such option api_v2_admin in group [identity-feature-enabled]


Even tests related to quotas fail with same error, 
[though quotas is not supported in our environment, was expecting Skipped status instead]

--- Additional comment from Ihar Hrachyshka on 2017-10-30 15:00:23 EDT ---

[ihrachys@laptop tempest]$ git show 1413ba9c0686956463d0f4e61c44927fba45541f
commit 1413ba9c0686956463d0f4e61c44927fba45541f
Author: Andrea Frittoli <andrea.frittoli@gmail.com>
Date:   Fri Apr 21 14:33:23 2017 +0100

    Add api_v2_admin flag
    
    Only run Identity V2 admin tests if the identity v2 admin API is
    available. The new config flag is set to True by default.
    
    Change-Id: I43459cb1a96e725dde41e23962e367dbdc345686

...

[ihrachys@laptop tempest]$ git tag --contains 1413ba9c0686956463d0f4e61c44927fba45541f
16.1.0
17.0.0

We need to backport this commit to tempest to support the option that the test relies on.

--- Additional comment from Ihar Hrachyshka on 2017-10-30 15:01:13 EDT ---

I believe we need to clone the bug to tempest component, since I imagine this bug should stay specific to certification program. Correct?

--- Additional comment from Ihar Hrachyshka on 2017-11-08 12:54:12 EST ---

I believe the fix belongs to tempest repo not puppet. Changing component.

Comment 1 Ihar Hrachyshka 2017-11-13 18:26:42 UTC
We are waiting for new ocata release from RDO that will include the fix.

Comment 2 Ihar Hrachyshka 2017-11-13 18:27:09 UTC
tempest-16.1.0 is the desired package version.

Comment 3 Ihar Hrachyshka 2017-11-30 18:42:51 UTC
RDO bumps are merged, we are waiting for next sync to OSP11.

Comment 6 Arie Bregman 2017-12-18 10:36:13 UTC
*** Bug 1526750 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-02-13 16:38:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0311


Note You need to log in before you can comment on or make changes to this bug.