Bug 1513188 - multipage djvu files are misidentified
Summary: multipage djvu files are misidentified
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: djvulibre   
(Show other bugs)
Version: 27
Hardware: x86_64 Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1507305 1513710 (view as bug list)
Depends On: 1514085
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 22:38 UTC by Luca Giuzzi
Modified: 2018-03-29 05:17 UTC (History)
6 users (show)

Fixed In Version: djvulibre-3.5.27-5.fc27 djvulibre-3.5.27-8.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-20 17:16:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1507305 None None None Never

Description Luca Giuzzi 2017-11-14 22:38:41 UTC
Description of problem:

djvulibre installs /usr/share/mime/packages/djvulibre-mime.xml
conflicting with freedesktop.org.xml so, evince is unable to open
djvu files.



Version-Release number of selected component (if applicable):


How reproducible:

Install both djvulibre and evince-djvu
Try to open a djvu document; evince fails complaining about images of
type image/vnd.djvu instead of image/vnd.djvu+multipage

xdg-mime query filetype filename.djvu

confirms the misidentification

Steps to Reproduce:
1. install both evince-djvu and djvulibre
2. execute xdg-mime query filetype filename.djvu where filename.djvu is a multipage djvu file
3. the reported filetype is wrong (and if evince is used, then it complains and it does not open the file)

Actual results:

The file is identified as image/vnd.djvu

Expected results:

The file should be identified as image/vnd.djvu+multipage

Additional info:

Renaming /usr/share/mime/packages/djvulibre-mime.xml apparently fixes the problem.

This is related to bug 1507305 but the problem is not with gnome or evince (rather with djvulibre).

Comment 1 Luca Giuzzi 2017-11-15 06:59:49 UTC
Incidentally, the problem is due to a conflict between shared-mime-info and djvulibre (evince is just the program which displayed the issue first).

I forgot to mention the relevant versions of the installed packages:

djvulibre-3.5.27-4.fc27.x86_64
shared-mime-info-1.9-1.fc27.x86_64

[evince-djvu is version 3.26.0.1.fc27.x86_64 but, once more, it does not seem relevant]

Comment 2 Marek Kašík 2017-11-16 17:11:33 UTC
I will remove the XML from djvulibre because the one in shared-mime-info is correct and differentiate between DjVu Document and DjVu Image. But I will wait for decision of rpm maintainer on #1514085 because the "%transfiletriggerpostun" scriptlet is not triggered once the old package is removed and hence the MIME database is not updated.

Comment 3 Toni Andjelkovic 2017-11-18 23:44:29 UTC
A workaround is to add "image/vnd.djvu" to "/usr/lib64/evince/4/backends/djvudocument.evince-backend".

Comment 4 Caolan McNamara 2017-11-20 15:26:10 UTC
*** Bug 1513710 has been marked as a duplicate of this bug. ***

Comment 5 Caolan McNamara 2017-11-20 15:27:12 UTC
*** Bug 1507305 has been marked as a duplicate of this bug. ***

Comment 6 Bastián Díaz 2017-11-20 16:21:22 UTC
My solution was to uninstall the djvulibre package (Evince only needs djvulibre-libs), manually remove the xml files and update mime info database.

The conclusion reached in GNOME bugzilla (https://bugzilla.gnome.org/show_bug.cgi?id=787481) is that it was a problem in the upstream package, so I opened a ticket in sourceforge (https://sourceforge.net/p/djvu/bugs/283/).

Comment 7 Bastien Nocera 2018-01-20 13:54:12 UTC
I also added a work-around to shared-mime-info, because this still seems to be a problem in Fedora 27.
https://bugzilla.gnome.org/show_bug.cgi?id=787481#c23

Comment 8 Marek Kašík 2018-02-07 14:28:40 UTC
Since a fix for the bug #1514085 just got into stable I'll wait 1 week before removing the "djvulibre-mime.xml" from djvulibre so that the update is done by updated rpm and the trigger works.

Comment 9 Marek Kašík 2018-02-14 14:02:55 UTC
I've just removed the "djvulibre-mime.xml" file from djvulibre (djvulibre-3.5.27-5.fc27). If the issue still shows up try to update "rpm" package (to at least rpm-4.14.1-1.fc27) and reinstall djvulibre after that ("dnf reinstall "djvulibre*"").

Comment 10 Fedora Update System 2018-02-14 14:11:15 UTC
djvulibre-3.5.27-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d964753372

Comment 11 Fedora Update System 2018-02-14 18:28:37 UTC
djvulibre-3.5.27-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d964753372

Comment 12 Fedora Update System 2018-02-20 17:16:03 UTC
djvulibre-3.5.27-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.