Bug 151347 - installer hangs when loading sata_sil module
installer hangs when loading sata_sil module
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-03-17 00:41 EST by Jason
Modified: 2015-01-04 17:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-19 04:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-03-17 00:41:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
ASUS A7N8X deluxe mobo (revision 2), XP3000 CPU, Sil3112a sata controller, 
when the sata controller is enabled, the installer gets to the loading sata_sil driver and i get the message "disabling irq#11" and the system hangs there.  this also happened throughout all of FC3's kernel releases and on the install CD's too and I know it was posted about previously but I though I would post it against FC4test1 in an attempt to get it fixed before FC4 gets released

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1177

How reproducible:
Always

Steps to Reproduce:
1.insert CD
2.boot system from CD
3.wait
  

Actual Results:  it loads the ohci1394 driver, then proceeds to attempt loading the sata)sil driver at which point it tries to disable irq#11 and the system hangs

Expected Results:  the installer should have loaded the driver and gone into the installation routine to start installing FC4test1

Additional info:
Comment 1 David Bentley 2005-03-24 11:15:07 EST
I have had similar results also since core 3 which I encountered it on and
confirm my problem still exists even with the latest boot.iso (24/03/05) from
RAWHIDE.

My configuration is is on an INTEL SE7505VB2 server board with twin XEONS and an
addin Firewire card. I

In my case also goes trough the loading ohci1394 driver but hangs at the
sata_sil stage with a Dissable IRQ #10 message.

I have tried with a noprobe option which bypasses the loading ohci1394 driver
but still fails in the same way at the sata_sil stage. I have drives attached to
the SATA controller but am trying to load the OS onto the PRIMARY MASTER
Parallel ATA drive.

debuging output that may be relavent follows:-

CTL ALT F3

* finished bus probing
* modules to insert libata sata_sil mii e100 e1000
* loaded libata from /modules/modules.cgz
* loaded sata_sil from /modules/modules.cgz
* loaded mii from /modules/modules.cgz
* loaded e100 from /modules/modules.cgz
* loaded e1000 from /modules/modules.cgz
* inserted /temp/libata.ko

CTL ALT F4

<0> Disabling IRQ #10
<7> ata1: dev 0 cfg 49:2f00 82:74e6 83:7fea 84:4023 85:74e9 86:3co2 87:4023 88:203f
<6> ata1: dev 0 ATA, max UDMA/100, 321672960 sectors: lba48
Comment 2 David Bentley 2005-04-17 13:44:10 EDT
Just for info tried fc4test2 with a result the same as above.
I will download the latest boot.iso and see if any progress has been made having
had quite a few kernel updates since fc4test2 was released.
Comment 3 Jason 2005-05-14 09:42:00 EDT
unfortunately with the release of fc4test3 just a few days ago now, this bug has
still remained unchanged
Comment 4 moylo 2005-06-14 05:24:54 EDT
I can confirm that this bug is still in FC4 final
Comment 5 Dave Jones 2005-06-27 19:30:42 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 6 Jason 2005-06-28 05:04:32 EDT
Unforutnately guys I can also confirm that this is still happening on FC4 Final
Comment 7 David Bentley 2005-07-04 17:24:45 EDT
This is still happening exactltly as described in comment #1 in FC4 FINAL.

see also my comment on bug 154070.
Comment 8 James Christie 2005-07-07 00:02:37 EDT
Hi guys...  I was having the same problem w/ another RedHat based O/S, as well
as Kubuntu...  I was able to get past the hang by using the "irqpoll" boot
option...    This worked great for the install, but then the system would do the
same hang upon reboot, so I just booted w/ a Knoppix disc and added irqpoll to
the kernel parameters in grub.conf...  Now all is well...  Give it a shot and
see if it works for FC4...  Good Luck...

James...
Comment 9 Jason 2005-07-15 06:23:53 EDT
Unfortunately the "irqpoll" trick still doesn't work even though a vanilla
kernel with the driver built in (no module) works flawlessly.  maybe that's the
key, not building the sii module as a module...
Comment 10 Dave Jones 2005-07-15 17:52:06 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 11 David Bentley 2005-07-20 16:22:53 EDT
I havent got FC4 installed on my Intel SE7505VB2 box as it hangs at boot as
described in comment #1.

So without a boot disk with this kernel on it how do you suggest I test it other
than using the latest boot.iso from the development tree.
Comment 12 David Bentley 2005-08-06 05:25:24 EDT
The "irqpoll" kernel option does not work for me either on an FC4 instalation on
my Intel SE7505VB2 box but last night I downloaded the latest "DEVELOPMENT"
boot.iso (5/8/05) to see what happens.

It still hangs with the "Dissable IRQ #10 message" so I tried the "irqpoll"
option and this time it looks as if an install would work OK , but it was rather
late so I shall proceed with an FTP install sometime over the weekend.
Comment 13 David Bentley 2005-08-07 10:33:16 EDT
I can report that I have done an FTP install OK but had to get a later boot.iso to
do it with (6/8/05) and that anaconda failed with a python traceback error so 
did a text install and picked the custom option and got all the other packages 
later on with YUM after editing the repo files used so that updates/installs were 
done from developmemt and extras-development.

Should this now be moved from fc4 to devel.
Comment 14 Dave Jones 2005-11-10 14:42:17 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 15 Dave Jones 2005-11-19 04:05:31 EST
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.

Note You need to log in before you can comment on or make changes to this bug.