Bug 1513583 - [downstream clone - 4.2.0] [RFE] Add a link to CA certificate on the main landing page
Summary: [downstream clone - 4.2.0] [RFE] Add a link to CA certificate on the main lan...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Greg Sheremeta
QA Contact: samuel macko
URL:
Whiteboard:
Depends On: 1433676
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 16:13 UTC by rhev-integ
Modified: 2019-05-16 13:07 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
A link to the Engine's CA certificate has been added to the Welcome page.
Clone Of: 1433676
Environment:
Last Closed: 2018-05-15 17:46:12 UTC
oVirt Team: UX
Target Upstream Version:
pstehlik: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:47:48 UTC
oVirt gerrit 84120 0 master MERGED engine: add CA certificate link to welcome page 2017-11-15 16:14:36 UTC

Description rhev-integ 2017-11-15 16:13:56 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1433676 +++
======================================================================

Description of problem:

I'm quite sure we used to have a link to the Engine's CA certificate in the landing page. Can't see it now.

Version-Release number of selected component (if applicable):
[root@lago-basic-suite-master-engine ~]# rpm -qa |grep webadmin
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170317143110.git21edba0.el7.centos.noarch
ovirt-engine-webadmin-portal-debuginfo-4.2.0-0.0.master.20170317143110.git21edba0.el7.centos.noarch

(Originally by Yaniv Kaul)

Comment 1 rhev-integ 2017-11-15 16:13:57 UTC
I don't recall it, and I don't see anything in the history of packaging/branding/ovirt.brand/welcome_page.template

@Alexander, do you recall this?

(Originally by Greg Sheremeta)

Comment 3 rhev-integ 2017-11-15 16:14:02 UTC
I don't think we had such a link.
We do have a URL providing that, but I don't recall having any link there.

(Originally by Oved Ourfali)

Comment 4 rhev-integ 2017-11-15 16:14:07 UTC
We never had one on the welcome page, there is one on the client resources page though.

(Originally by Alexander Wels)

Comment 5 rhev-integ 2017-11-15 16:14:11 UTC
"For using web-browser-based console clients, the certificate authority must be imported in your browser since the communication is secured. You can download the certificate authority by navigating 'https:///ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA'."

http://www.ovirt.org/documentation/admin-guide/virt/console-client-resources/

Thanks Alexander.

@Yaniv, ok to close?

(Originally by Greg Sheremeta)

Comment 6 rhev-integ 2017-11-15 16:14:15 UTC
Converting it to a RFE.

(Originally by Yaniv Kaul)

Comment 7 rhev-integ 2017-11-15 16:14:20 UTC
*** Bug 1467817 has been marked as a duplicate of this bug. ***

(Originally by Greg Sheremeta)

Comment 11 samuel macko 2017-12-08 12:20:50 UTC
Verified in RHVM version 4.2.0-0.6.el7.

Comment 15 errata-xmlrpc 2018-05-15 17:46:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 16 Franta Kust 2019-05-16 13:07:08 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.