Bug 151382 - kernel-smp hangs, screen goes blank while loading audio modules
kernel-smp hangs, screen goes blank while loading audio modules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 151418 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 09:23 EST by Tom Wood
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.12-1_1390_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 14:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v from this machine (2.78 KB, text/plain)
2005-03-17 09:24 EST, Tom Wood
no flags Details
lshal from this machine (49.46 KB, text/plain)
2005-03-17 09:25 EST, Tom Wood
no flags Details
lsmod before modprobing matroxfb-base (439 bytes, text/plain)
2005-03-17 16:35 EST, Tom Wood
no flags Details
lsmod after modprobing matroxfb-base (821 bytes, text/plain)
2005-03-17 16:36 EST, Tom Wood
no flags Details
stack trace of the failed "modprobe matroxfb_base" (2.33 KB, text/plain)
2005-03-17 17:51 EST, Tom Wood
no flags Details

  None (edit)
Description Tom Wood 2005-03-17 09:23:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Boot process stops and screen goes blank when booting kernel-smp while running in /etc/rc.sysinit at "Initializing hardware" just after "audio" comes up.

There is no audio hardware in this machine.  It's a dual processor P III running on a Via 686 chipset (Abit VP6).

This machine ran fine under RH9 - FC3.  This is a fresh install of FC4t1.

System at this point hard locks, sysrq doesn't respond.

UP kernel works.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.11-1.1177_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot the kernel-smp.
2. Watch system lock up.
3.
  

Actual Results:  Hard lock as described above

Expected Results:  System should have booted.

Additional info:
Comment 1 Tom Wood 2005-03-17 09:24:59 EST
Created attachment 112092 [details]
lspci -v from this machine
Comment 2 Tom Wood 2005-03-17 09:25:53 EST
Created attachment 112093 [details]
lshal from this machine
Comment 3 Tom Wood 2005-03-17 16:34:19 EST
*** Bug 151418 has been marked as a duplicate of this bug. ***
Comment 4 Tom Wood 2005-03-17 16:35:29 EST
Created attachment 112109 [details]
lsmod before modprobing matroxfb-base
Comment 5 Tom Wood 2005-03-17 16:36:11 EST
Created attachment 112110 [details]
lsmod after modprobing matroxfb-base
Comment 6 Tom Wood 2005-03-17 16:40:11 EST
The lockups and bad behaving video are caused by a segfaulting matroxfb-base
module.  This doesn't segfault in the UP kernel, just the SMP kernel.  I
disabled the "other" category in /etc/rc.sysinit around line 210 or so and
manually modprobed the modules it specified.  The others (parport_pc and
uhci-hcd) were fine.

Please see the last two attachments for details from lsmod.
Comment 7 Tom Wood 2005-03-17 17:51:28 EST
Created attachment 112113 [details]
stack trace of the failed "modprobe matroxfb_base"
Comment 8 Tom Wood 2005-03-21 10:01:28 EST
Still exists in 1191 kernel.
Comment 9 Tom Wood 2005-03-25 14:41:10 EST
Still exists in 1202 kernel.
Comment 10 Tom Wood 2005-03-29 11:11:15 EST
Still no matrox love in 1208 SMP kernel.
Comment 11 Tom Wood 2005-03-31 16:00:49 EST
The 1219 kernel is worse.  Now the UP kernel also hangs in the same spot.
Comment 12 Tom Wood 2005-04-04 14:22:11 EDT
Works fine now in 1225 kernel, UP and SMP both.  Get a rather disconcerting font
change and a momentary blinking out of the video, but that's to be expected.
Comment 13 A.J. Perry 2005-04-24 19:58:30 EDT
I have a similar problem on my machine.  It boots up, then starts loading the
GUI, and gets as far as 'setting hostname'.  Then the display goes black.  There
is still a signal to the screen, because the LED stays green, but there's no
display, and no mouse curser.

I have to reboot several times to get any further than this.  I know it's not
booting any further, because I can't SSH into it.  It does however show up in my
DHCP table.

I'm running Fedora Core 2, 2.6.11-1.14_FC3, on a Pentium 3, 500MHz, AOpen AX6BC
motherboard with the latest bios, 256MB ram, PA700 pro display adapter.  If I
can get it to boot any further, I might be able to get more system info.  
Comment 14 Dave Jones 2005-06-27 19:25:33 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Note You need to log in before you can comment on or make changes to this bug.