Bug 151403 - hw_random is loaded even when RNG not present on IBM T41
hw_random is loaded even when RNG not present on IBM T41
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dustin Kirkland
Brian Brock
:
Depends On:
Blocks: 130350
  Show dependency treegraph
 
Reported: 2005-03-17 12:23 EST by David Lehman
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.12-1.1372
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 04:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2005-03-17 12:23:53 EST
Description of problem:
This is on an IBM Thinkpad T41. The hw_random driver is associated with the
following device:

  00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 81)
  or
  00:1e.0 Class 0604: 8086:2448 (rev 81)
The driver loads and initializes successfully but there doesn't appear to be an
RNG capability there. I say this because if I try to start rngd it hangs on it's
first attempt to read from /dev/hw_random.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Always (on T41, that is)

Steps to Reproduce:
1. modprobe -r hw_random
2. modprobe hw_random
3. rngd
  
Actual results:
rngd hangs waiting for read on /dev/hw_random

Expected results:
rngd daemonizes and runs happily

Additional info:
This will also need fixing in RHEL4 as it's blocking 130350. I have only
reproduced this on FC3 although I'm fairly certain it's resent in RHEL4 as well.

Any further details will be happily provided upon request.
Comment 3 Dave Jones 2005-07-15 14:45:57 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 David Lehman 2005-08-03 20:29:58 EDT
kernel-2.6.12-1.1372_FC3 fixes the problem. Closing...
Comment 5 David Lehman 2005-08-03 20:31:19 EDT
Okay, I didn't close it. MODIFIED seemed more appropriate.

Note You need to log in before you can comment on or make changes to this bug.