Bug 1514550 - [RFE] seed the manageiq-client python binding in the appliance [NEEDINFO]
Summary: [RFE] seed the manageiq-client python binding in the appliance
Keywords:
Status: CLOSED DUPLICATE of bug 1573658
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 18:36 UTC by John Hardy
Modified: 2018-08-09 22:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 22:06:03 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
jrafanie: needinfo? (jhardy)
gtanzill: needinfo? (jhardy)


Attachments (Terms of Use)

Description John Hardy 2017-11-17 18:36:02 UTC
The appliance does not currently include the python binding library manageiq-client.

please seed it for shipping.

thanks

Comment 2 Joe Rafaniello 2017-12-08 20:27:48 UTC
Do you mean https://github.com/ManageIQ/manageiq-api-client-python ?

If so, is GPL2 ok?
Is it correct in assuming that this would need to become an rpm?  Is this already done?
If this is installed as an rpm, are there other steps required?

If you've done this manually already, please provide the steps you followed and more details, thank you!

Comment 3 Gregg Tanzillo 2017-12-12 19:23:12 UTC
John, ping - need info from you since this is flagged as a blocker. Thanks.

Comment 4 Brandon Dunne 2018-08-09 22:06:03 UTC
Dependency problems: (RPMs, Python packages, Ruby Gems, Ansible modules, etc.)

Several of us on the platform team met recently to discuss dependency problems and came up with the following decisions:
- The appliance will carry dependencies for the application and any necessary debugging tools
- The application itself will declare all of its dependencies as it has in the past
- Application plugins will declare their dependencies in a way that the application / appliance build code can aggregate and install them
- Customer dependencies will need to be installed and maintained by customers since it is impossible for us to maintain and upgrade that list of dependencies.  We can not guarantee that any changes to these dependencies will not break scripts that are not maintained by the engineering team.

*** This bug has been marked as a duplicate of bug 1573658 ***


Note You need to log in before you can comment on or make changes to this bug.