Bug 151461 - Won't let me add comment, thinks I'm trying to change resolution status
Won't let me add comment, thinks I'm trying to change resolution status
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
: 151631 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 00:54 EST by Terry Griffin
Modified: 2007-04-18 13:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 23:22:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Terry Griffin 2005-03-18 00:54:06 EST
Description of problem:

I'm trying to add a comment to bugzilla entry 151334, leaving the status
as "New". But when I click on the "Submit" button it gives me a "Not Allowed"
error stating:

"You tried to change the Resolution field from no value to NOTABUG, but only
the owner or submitter of the bug, or a sufficiently empowered user, may
change that field."

Yes, it's true that the resolution field contains "NOTABUG" but I did not
check the "Resolved" checkbox. The "leave as new" box is checked. And worse,
the resolution status pull-down menu provides no option *other* than NOTABUG.
So basically there's no escape and it's impossible to add a comment.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. Try to add comment to 151334.
2. Leave bug status as "New"
3. Click "Submit"
  
Actual results:

Get above "not allowed" error.

Expected results:

No error and comment added.

Additional info:
Comment 1 David Lawrence 2005-03-18 11:31:32 EST
As I have not personnally been able to reproduce this, I have heard of several
other people having a similar problem. Is it asking you to log in after
submitting the comment and then giving the error or are you already logged in?
Also which browser/version are you using? 
Comment 2 Terry Griffin 2005-03-18 14:48:19 EST
Without logging in I did a query to see if anyone else had observed
the kdeinit problem. I found entry #151334 that was very similar to
what I was seeing, so I went to add some additional information I'd found
while debugging the problem. After entering the comment and clicking on
"Save Changes" it asked me to log in. I logged in and then I got the
"not allowed" error. Subsequent attempts to add the comment also failed
with the same error but it did not prompt for login information again.

I've done this exact sequence many times before though it's been a while
since the last one. That is, query/find/add-comment without logging in,
prompt for login, and then comment accepted.

The browser was Firefox on FC3.

Now let's see what happens when I click "Save Changes"... (This time I'm
already logged in using Mozilla on FC2.)
Comment 3 Terry Griffin 2005-03-18 14:51:09 EST
Well even though I was already logged in when entering that last
comment, it prompted for login information anyway. Then it (obviously)
it accepted the comment. I have cookies enabled so I'm not sure what's
up with that.
Comment 4 David Lawrence 2005-03-18 14:57:27 EST
The cookie format changed from the old bugzilla to the new bugzilla. I added
code in to account for both formats which should keep people from having to
remove their bugzilla.redhat.com cookies. But there has been a few people who
still had trouble that removing their bugzilla cookies was able to fix. Can you
try doing that in your Firefox preferences and see if Bugzilla remembers you are
logged in for each page after that?
Comment 5 Terry Griffin 2005-03-18 16:33:43 EST
The login-again problem was with Mozilla, not Firefox. But I'll try this
anyway.

I deleted all my bugzilla.redhat.com cookies from Mozilla, I'm now logged in,
and when I finished typing this I'll click on "Save Changes".
Comment 6 Terry Griffin 2005-03-18 16:35:51 EST
Okay, that time it didn't have me re-login. Progress is progress.

When I get home I'll try deleting cookies in Firefox and see if that solves
anything.
Comment 7 Terry Griffin 2005-03-18 22:56:00 EST
Back to Firefox, FC3, and trying to add a comment to #151334:

- I deleted all bugzilla.redhat.com cookies.
- I went to bug #151334 _without_ logging in to bugzilla.
- I added a comment and submitted it.
- bugzilla prompted for login information.
- After accepting my login I got the same "not allowed" error as before.

I logged out of bugzilla to start fresh. Then:

- I logged in to bugzilla _before_ going to bug #151334.
- Then I went to bug #151334 and added a comment.
- Submitting the comment succeeded!

So it would appear that the root of all evil is the intervening login.
It gets bugzilla and/or Firefox all confused.
Comment 8 David Lawrence 2005-03-18 23:47:08 EST
Ok, that does help to narrow it down a bit. Probably what is happening is that
during the intervening login screen, all of the previous form values from the
bug edit page, have to be listed as hiddden form values in the HTML generated
for the login page. Something important is being either omitted or is getting
shuffled somehow which is confusing Bugzilla. I will need to do some research
into the code and hopefully come up with a fix. Thanks for all of your
troubleshooting help.
Comment 9 Sean Earp 2005-03-20 12:51:34 EST
Hello,

I am running into the exact same problem.  If there is any testing that I can do to help find a resolution, 
please let me know.  I run into the issue exactly as Terry does, when I attempt to update a bug without 
first logging in...

-Sean
Comment 10 Michael A. Peters 2005-03-21 03:28:16 EST
It bit me too.
Disabling cookies does not work.
Clearing cookies does not work.
Only thing that works is loging in first - then going to the bug.
So its something with the login process - even when you clear all your cookies
first.
Comment 11 David Lawrence 2005-03-21 10:49:31 EST
*** Bug 151631 has been marked as a duplicate of this bug. ***
Comment 12 David Lawrence 2005-03-21 14:02:58 EST
Ok, I found the problem and have made a code change to hopefully solve the
issue. Can each of you please verify the fix somehow by adding test comments on
a bug you do not own without being logged in first? Thanks for your patience.
Comment 13 Need Real Name 2005-03-21 15:25:23 EST
Looks like it works for me :)
Comment 14 Sean Earp 2005-03-21 22:23:55 EST
Works for me as well!
Comment 15 Terry Griffin 2005-03-21 22:52:32 EST
Ditto.
Comment 16 David Lawrence 2005-03-21 23:22:40 EST
Three times the charm ;) Please reopen this issue if you still experience the
problem. Thanks for all of the help and patience.

Note You need to log in before you can comment on or make changes to this bug.