Bug 1515153 - cephmetrics-ansible iSCSI gateway not installed properly
Summary: cephmetrics-ansible iSCSI gateway not installed properly
Status: CLOSED DUPLICATE of bug 1595288
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Metrics
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.*
Assignee: Zack Cerza
QA Contact: ceph-qe-bugs
Bara Ancincova
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-11-20 09:28 UTC by Lubos Trilety
Modified: 2019-01-09 23:02 UTC (History)
6 users (show)

(edit)
.The Red Hat Ceph Storage Dashboard cannot monitor iSCSI gateway nodes

The `cephmetrics-ansible` playbook does not install required Red Hat Ceph Storage Dashboard packages on iSCSI gateway nodes. As a consequence, the Red Hat Ceph Storage Dashboard cannot monitor the iSCSI gateways, and the "iSCSI Overview" dashboard is empty.
Clone Of:
(edit)
Last Closed: 2019-01-09 23:02:14 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph cephmetrics issues 150 None None None 2017-11-20 19:04 UTC
Red Hat Bugzilla 1595288 None ASSIGNED [cephmetrics] iSCSI Overview grafana page does not display graphs/values 2019-07-09 13:56 UTC

Internal Trackers: 1595288

Description Lubos Trilety 2017-11-20 09:28:14 UTC
Description of problem:
cephmetrics-ansible playbook.yml does not install required packages on machines, where ceph iSCSI gateways are. 

Version-Release number of selected component (if applicable):
cephmetrics-ansible-1.0-7.el7cp.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare some ceph cluster with iSCSI gateways
2. Try to install ceph-metrics
3.

Actual results:
ceph-metrics is installed however ceph iSCSI gateway machines are not monitored as no cephmetrics packages are installed on them.
'iSCSI Overview' dashboard in Grafana is empty.

Expected results:
ceph-metrics is working and 'iSCSI Overview' dashboard in Grafana shows correct data.

Additional info:

Comment 6 dn-infra-peta-pers 2018-11-09 14:44:16 UTC
Hi guys,

The issue seems to be that cephmetrics-ansible is expecting a [iscsis] section in ansible inventory file while the RHCS block device guide states this section should be called [iscsigws]. Adding a [iscsis] section is enough to have the prometheus-node-exporter package correctly installed on iSCSI targets and metrics recorded and exposed on iSCSI Grafana dashboards.

You can refer to these 2 commits from Zack:
https://github.com/ceph/cephmetrics/commit/a99fdea00f19bedb8093484330a34619d7e682dd
https://github.com/ceph/cephmetrics/commit/9b5dafd45d22769fb6c33a93df2d31d363d6c673

And the RHCS block device guide: 
https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/block_device_guide/#iscsi-config-target-ansible

Regards,
Frédéric.

Comment 7 Christina Meno 2019-01-09 23:02:14 UTC

*** This bug has been marked as a duplicate of bug 1595288 ***


Note You need to log in before you can comment on or make changes to this bug.