Bug 1595288 - [cephmetrics] iSCSI Overview grafana page does not display graphs/values
Summary: [cephmetrics] iSCSI Overview grafana page does not display graphs/values
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Metrics
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 3.3
Assignee: Zack Cerza
QA Contact: Madhavi Kasturi
Bara Ancincova
URL:
Whiteboard:
: 1515153 1656053 (view as bug list)
Depends On:
Blocks: 1494421 1584262 1584264
TreeView+ depends on / blocked
 
Reported: 2018-06-26 13:52 UTC by Madhavi Kasturi
Modified: 2020-02-20 16:59 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
See Doc Text in Bug 1656053
Clone Of:
Environment:
Last Closed: 2020-02-20 16:59:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1515153 None CLOSED cephmetrics-ansible iSCSI gateway not installed properly 2019-11-06 13:03:29 UTC
Red Hat Knowledge Base (Solution) 4104851 Troubleshoot None Ceph Storage Dashboard: The _iSCSI Overview_ dashboard does not display graphs if the [iscsigws] role is included in the... 2019-05-03 11:03:37 UTC

Internal Links: 1515153

Comment 6 Madhavi Kasturi 2018-07-05 07:42:15 UTC
Raised bug 1598344, in 3.1 for issue observed in comment #4

Comment 10 Madhavi Kasturi 2018-07-10 08:18:14 UTC
Hi Erin,

Ignore my previous comment #9.

The doc text from comment #8, lgtm 

"The 'iSCSI Overview' Grafana page does not behave correctly When using the Red Hat Ceph Storage metrics Dashboard, the 'iSCSI Overview' Grafana page does not display any graphs or values as it is expected to"

Comment 11 dn-infra-peta-pers 2018-11-09 14:44:31 UTC
Hi guys,

The issue seems to be that cephmetrics-ansible is expecting a [iscsis] section in ansible inventory file while the RHCS block device guide states this section should be called [iscsigws]. Adding a [iscsis] section is enough to have the prometheus-node-exporter package correctly installed on iSCSI targets and metrics recorded and exposed on iSCSI Grafana dashboards.

You can refer to these 2 commits from Zack:
https://github.com/ceph/cephmetrics/commit/a99fdea00f19bedb8093484330a34619d7e682dd
https://github.com/ceph/cephmetrics/commit/9b5dafd45d22769fb6c33a93df2d31d363d6c673

And the RHCS block device guide: 
https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/3/html-single/block_device_guide/#iscsi-config-target-ansible

Regards,
Frédéric.

Comment 12 Boris Ranto 2018-11-22 17:04:04 UTC
Hi Frederic,

great catch! We should probably fix that for 3.2 or document your workaround. Zack, what do you think?

Regards,
Boris

Comment 14 Christina Meno 2019-01-09 22:59:56 UTC
Zack would you please let us know the status of this?

Comment 15 Christina Meno 2019-01-09 23:01:11 UTC
*** Bug 1656053 has been marked as a duplicate of this bug. ***

Comment 16 Christina Meno 2019-01-09 23:02:14 UTC
*** Bug 1515153 has been marked as a duplicate of this bug. ***

Comment 21 Servesha 2019-03-18 09:30:46 UTC
Hello ,

Regarding case : #02337240

Customer is facing the same issue. May I please know the status of this bug. Or can we provide any workaround possibly?

Waiting for response!

Thanks

Regards,
Servesha

Comment 22 Boris Ranto 2019-03-18 12:50:18 UTC
A workaround would be to have both [iscsis] as well as [iscsigws] sections in the ansible hosts file.

Comment 23 Servesha 2019-03-18 13:06:14 UTC
Hello Boris ,

Thank you for the reply. I will suggest this workaround to the customer.

Regards,
Servesha

Comment 24 Servesha 2019-03-18 13:34:00 UTC
Hello Boris,

I have a question. If we mention both [iscsis] as well as [iscsigws] in ansible hosts file, customer will need to run site.yml (or site-docker.yml) playbook. Playbook can be run using --limit option. So, the question is, when using --limit option what command will be right?

#ansible-playbook site.yml --limit  iscsigws  OR

#ansible-playbook site.yml --limit iscsis

Awaiting response!

Regards,
Servesha

Comment 25 dn-infra-peta-pers 2019-03-18 13:42:36 UTC
Hello,

I would say this one: ansible-playbook site.yml --limit iscsis,iscsigws

Frédéric.

Comment 26 Boris Ranto 2019-03-18 16:04:42 UTC
If you are talking site.yml as in ceph-ansible then that should support iscsigws. For the cephmetrics-ansible (playbook.yml), you should use iscsis. Alternatively, you can use the syntax as suggested in the above comment, that should be the safest option and can be used for both ceph-ansible as well as cephmetrics-ansible.

Comment 27 Servesha 2019-03-26 08:33:14 UTC
Hello Boris,

The customer was already aware of work around. And I asked if it is worked for him. But apparently it is not working for him. May I please know if we have some other way to provide to the customer? 

Thanks,

Best Regards,
Servesha

Comment 28 Boris Ranto 2019-04-11 11:36:33 UTC
Hey Servesha,

they only need to re-deploy cephmetrics after they have both iscsis and iscsigws in their ansible/hosts file. Re-deploying cephmetrics is generally less heavy than doing a full ceph deployment. It would be nice if they could re-run the full cephmetrics-ansible deployment scripts (without any --limit options). If that won't work then I would suggest purging the old cephmetrics installation and then doing a full re-deployment.

The deployment playbook should be located at

/usr/share/cephmetrics-ansible/playbook.yml

The purge playbook should be located at

/usr/share/cephmetrics-ansible/purge.yml

Regards,
Boris

Comment 29 Servesha 2019-04-12 01:46:01 UTC
Hello Boris,

I will check with the customer regarding purging the old cephmetrics installation. Thank you for your reply.

Best Regards,
Servesha

Comment 31 Giridhar Ramaraju 2019-08-05 13:09:44 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 32 Giridhar Ramaraju 2019-08-05 13:10:57 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri


Note You need to log in before you can comment on or make changes to this bug.