Bug 151585 - dmraid isn't started by installer (therefore it doesn't recognize RAID arrays created by Intel ICH6R OROM)
dmraid isn't started by installer (therefore it doesn't recognize RAID array...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 164336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-20 05:47 EST by tryptofon
Modified: 2008-02-15 17:38 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 17:38:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump (62.69 KB, text/plain)
2006-02-07 17:25 EST, Jun'ichi NOMURA
no flags Details

  None (edit)
Description tryptofon 2005-03-20 05:47:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:


Version-Release number of selected component (if applicable):
dmraid-1.0.0.6

How reproducible:
Always

Steps to Reproduce:
1.Start installation when there are only RAID arrays
2.When it comes to patritioning, installer informs that there are no disks to install to 

Actual Results:  installer informs that there are no disks to install to 

Expected Results:  I should be able to create partition on RAID array, and the nstallation should normally begin.

Additional info:

"dmraid -ay" should be executed before anaconda (installer)
Comment 1 Heinz Mauelshagen 2005-07-27 08:20:08 EDT
*** Bug 164336 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Khouzam 2005-12-06 02:28:21 EST
I would like to confirm I have the same problem with FC5test1 and an I686 or x86_64
Comment 3 Patrick Dalais 2006-01-27 09:06:42 EST
FC5 test2 has similar problem.

Intel motherboard SE7221BK1-E
ICH6R bios setting: enhanced - raid
Raid10 
4 x disk

all 4 disks are recognised but is seen by the installer at partition time as 4 
separate disks. /dev/sda thru to /dev/sdd

was expecting the array to be seen as a single device eg /dev/sda 

dont know if dmraid ran or not.

the ahci module did run at startup.

under Notable Features of FC5 Test2

was

* Support for dmraid in the installer (motherboard based raid).

is this still not fully functional?

there does not seem to be any relatively easy method of installing 
FC1/FC2/FC/FC4 on the ICH6 using the installation cd's and non of the intel 
drivers work with any of the Fedora's

The only reasonably hassle free installation left is RH9 with the intel 
supplied drivers. Normal simple install, load intel drivers, single array seen 
and install per usual. But RH9 is getting really old now.

It still doesnt work as cleanly as RH9 in FC5 test 2 on a fresh install 
Comment 4 Jun'ichi NOMURA 2006-02-07 17:25:15 EST
Created attachment 124343 [details]
anaconda dump

I tried FC5 test2 on Dell Precision 380 which has Intel ICH7 SATA RAID.
I could once see the DiskDruid shows SATA array as single disk
however the installer aborts during editing partitions.
And later, I cannot even enter in disk partitioning stage before
getting aborted.

The following information is taken on the system:
# dmraid -s
*** Group superset isw_ebeeihbgfg
--> Subset
name   : isw_ebeeihbgfg_MIRROR
size   : 312494080
stride : 256
type   : mirror
status : ok
subsets: 0
devs   : 2
spares : 0
# dmraid -r
/dev/sda: isw, "isw_ebeeihbgfg", GROUP, ok, 312499998 sectors, data@ 0
/dev/sdb: isw, "isw_ebeeihbgfg", GROUP, ok, 312499998 sectors, data@ 0
Comment 5 Lam Yat Ming 2006-04-04 00:31:59 EDT
I tried to install FC5 release in Intel SR1425BK (with embedded ICH6R Raid 0/1
controller).  The RAID function is enabled in the bios and the RAID Array are
set up with 2 250G HD.  During the installation, no raid array could be
discovered and the installer shows there are two hard drivers in the system:
/dev/sda and /dev/sdb

I tried Intel's driver for RHAS4.0 EM64T update 1 in my system, the system still
couldn't find the Raid Array.

Would Fedora support for Intel ICH5R/ICH6R/ICH7R SATA RAID controller?
Comment 6 Heinz Mauelshagen 2006-04-04 12:18:42 EDT
What does the BIOS say about the ATARAID type ?
I.e. is it Intel software RAID or does it tell something different ?
Comment 7 Lam Yat Ming 2006-04-05 04:14:56 EDT
Please find the following information for my system:

Intel Entry Server System SR1425BK1-E

Intel Embedded Server RAID Technology for ICH6R (Intel Website)
http://www.intel.com/support/motherboards/server/sb/cs-020406.htm

AMIBIOS
BIOS Version: SE7221BK1E.86B.P.05.00.0026
Processor Intel P4 3GHz

BIOS RAID Setting:
ATA/IDE Configuration - Enabled
RAID Technology - Enabled
AHCI Mode - Enabled
Stagger Spiunp Support - Enabled


Booting:

Auto-Dectecting Pri Master..IDE Hard Disk
Auto-Dectecting Sec Master..IDE Hard Disk

Pri Master: WDC WD2500JS-00MHB0 01.01C03
               Ultra DMA Mode-5, S.M.A.R.T. Capable and Status OK
...

Intel Embedded Server RAID Technology 5.3.10081534I

[PCI 0/1F] Intel Embedded Server RAID Technology
Scanning for Port 0 ... Responding. WDC WD2500JS-00M 238475MB UDMA5
Scanning for Port 1 ... Responding. WDC WD2500JS-00M 238475MB UDMA5
Scanning for Port 3 ... Not Responding.
Scanning for Port 4 ... Not Responding.

01 Logical drive(s) Configured.
Array#: 00
Mode: Reliability
Stripe Size: 64KB(128 Sectors)
No. Of Stripes: 02
DriveSize: 238352MB
Status: Online


Please select boot device:
CDROM: 3M-ASUS DVD-ROM E616
RAID:Intel(R) MB RAID



Fedora Installation Screen:

Select the drive(s) to use for this installation.
sda 238473 MB ATA WDC WD2500JS-00M
sdb 238473 MB ATA WDC WD2500JS-00M
Comment 9 Matthew Miller 2007-04-06 11:06:30 EDT
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.
Comment 10 petrosyan 2008-02-15 17:38:05 EST
Fedora Core 4 is not maintained anymore.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.