Bug 151628 - Firefox should respect MOZ_ENABLE_PANGO
Firefox should respect MOZ_ENABLE_PANGO
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-20 21:01 EST by Behdad Esfahbod
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 15:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2005-03-20 21:01:03 EST
Description of problem:

Seems like currently Firefox startup script is setting MOZ_ENABLE_PANGO=1
unconditionally, which makes one unable to turn Firefox Pango support off.
A trivial fix is to simply not set MOZ_ENABLE_PANGO if it's already set. 
Mozilla doesn't have this problem since it doesn't set MOZ_ENABLE_PANGO at all.


Version-Release number of selected component (if applicable):

firefox-1.0.1-1.3.2
Comment 1 Behdad Esfahbod 2005-03-20 21:03:00 EST
BTW, I just noted that setting MOZ_ENABLE_PANGO in Firefox is against what is
advertised in FC3 release notes:

          o Firefox and Mozilla can be enabled with pango rendering support,
            which enables many text layout features, including the rendering
            of CTL (Complex Text Layout) such as Indic languages.  To enable
            this, set the following environment variable when running Firefox
            or Mozilla:

            MOZ_ENABLE_PANGO=1

The problem is that the current Pango backend has serious
problems with Arabic, for example it hangs on some random pages, got
http://rira.ir/ for example.
Comment 2 Warren Togami 2005-03-20 21:06:56 EST
Have you reported this pango + arabic hang in Bugzilla?  This should go into a
separate bug.
Comment 3 Behdad Esfahbod 2005-03-22 00:07:15 EST
Pango hang is awaiting in bug 151767.  Another Pango+Arabic/Hebrew bug is being
worked at in Mozilla bugzilla:

  https://bugzilla.mozilla.org/show_bug.cgi?id=284927

So, while the hang is now known to be not Firefox specific, but the latter is
indeed a rendering problem with Pango Firefox.  So I personally appreciate if
pango rendering is disable by default (it was enable on Feb 24).  I've seen a
couple people so far complaining about update breaking their Firefox Persian
rendering.
Comment 4 Behdad Esfahbod 2005-03-28 01:37:06 EST
Well, with the newer firefox-1.0.2-1.3.1 it's even worse.  Both firefox and
mozilla have pango backend selected at compile time and it cannot be turned off
using environment variables anymore :(.  That means half of Persian/Arabic pages
cannot be rendered in FC3.
Comment 5 Christopher Aillon 2005-03-28 13:57:24 EST
You can use MOZ_DISABLE_PANGO=1 now.
Comment 6 Behnam [:ZWNJ] Esfahbod 2005-04-12 16:42:41 EDT
Thanks Mr. Aillon.

But Thunderbird still have pango enabled and doesn't listen to
MOZ_DISABLE_PANGO=1.  So the arabic/persian/hebrew problem exicts on RSS feeds
and HTML mails yet.
Comment 7 Behdad Esfahbod 2005-04-12 16:53:21 EDT
I still believe the whole "on by default" is a bigger change than to fit FC3
updates.  Moreover, I believe they all should keep respecting MOZ_ENABLE_PANGO,
though they are free to decide whatever if it's not defined.  MOZ_DISABLE_PANGO
is not documented anywhere.  MOZ_ENABLE_PANGO is in the release notes.

Note You need to log in before you can comment on or make changes to this bug.